Opened 2 years ago

Closed 2 years ago

#5662 closed change (duplicate)

[emscripten] Create patterns.ini parser

Reported by: sergz Assignee:
Priority: P3 Milestone:
Module: Core Keywords:
Cc: trev Blocked By:
Blocking: #4122, #5137 Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

As a part of #5137 we should be able to parse patterns.ini.

What to change

In accordance with #5661 there should be PatternsIniParser which is aware about our INI format. Since the serialization of subscription properties is left in corresponding Subscription classes (#5661), there should be a static SubscriptionPtr Subscription::Parse(const SomeKeyValues&) method which can create an instance of corresponding Subscription class and set corresponding properties. In accordance with the current implementation of INIParser there should be either void Subscription::addFilter(Filter&) method adding a filter to the end of the subscription filter list or void Subscription::setFilters(Filters&&) method, both are not notifying. It could be helpful if they can be re-used by a parser of DownloadableSubscription (#5146).

Change History (3)

comment:1 follow-up: Changed 2 years ago by trev

Am I missing something or is this a duplicate of #4128?

comment:2 Changed 2 years ago by trev

Note also that this isn't blocking #5137, it's the other way round.

comment:3 in reply to: ↑ 1 Changed 2 years ago by sergz

  • Resolution set to duplicate
  • Status changed from new to closed

Replying to trev:

Am I missing something or is this a duplicate of #4128?

Right, it's a duplicate, an overlook on my side.

Note: See TracTickets for help on using tickets.