Opened 2 years ago

Closed 17 months ago

#5663 closed defect (duplicate)

[webextension] Could not establish connection error after fresh install

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: kzar, sebastian, mjethani Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 2.99.0.1838beta
Firefox 54/55 / Windows 7

How to reproduce

  1. Install ABP WebExtension build.
  2. Open extension debug console.

Observed behaviour

Firefox 55/54:
If a fresh install, with extension data deleted the following error occurs. If re-installed with existing data still present, the error does not occur.

Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist ExtensionCommon.jsm:265

Not sure if it breaks any functionality or not.

Expected behaviour

Error to not occur.

Change History (4)

comment:1 Changed 22 months ago by kzar

  • Cc kzar sebastian mjethani trev added
  • Component changed from Unknown to Platform

comment:2 Changed 21 months ago by kzar

  • Summary changed from [webextensions] Could not establish connection error after fresh install to [webextension] Could not establish connection error after fresh install

comment:3 Changed 20 months ago by fhd

  • Cc trev removed

comment:4 Changed 17 months ago by sebastian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6498.

Note: See TracTickets for help on using tickets.