Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5666 closed defect (fixed)

Version number in AppxMainfest.xml must end with ".0"

Reported by: sebastian Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-3.0-for-Firefox
Module: Automation Keywords:
Cc: oleksandr, tlucas Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29542744

Description (last modified by sebastian)

How to reproduce

  1. Create a build for Microsoft Edge with build number in version string
    • ./build.py -t edge build -b 1234
  2. Upload the build to the Windows Store

Observed behaviour

The submission fails because the fourth component of the version number must be 0 in AppxManifest.xml. (The version given in mainfest.json is not effected.)

Previously a bug (#5649) caused the build number to be ignored by accident.

Expected behaviour

Replace the fourth component in the version number given in AppxManifest.xml with 0. Keep using the full version number in manifest.json.

Change History (5)

comment:1 Changed 2 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 2 years ago by abpbot

comment:4 Changed 2 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 2 years ago by sebastian

  • Description modified (diff)
Note: See TracTickets for help on using tickets.