Opened 2 years ago

Closed 2 years ago

Last modified 11 months ago

#5668 closed defect (fixed)

Version number in AppxMainfest.xml must include build number

Reported by: sebastian Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-3.0-for-Firefox
Module: Automation Keywords:
Cc: oleksandr, tlucas Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29542845

Description (last modified by sebastian)

How to reproduce

  1. Create a build for Microsoft Edge with build number in version string
    • ./build.py -t edge build -b 1234
  2. Upload the build to the Windows Store
  3. Repeat and advance the build number (given with -b)

Observed behaviour

The second upload to the Windows Store fails with following error:

Appx packages (including previously published and currently uploaded) must be uniquely identified by their full names. You have provided two packages with the full name PFN=EyeoGmbH.AdblockPlusdevelopmentbuild_d55gg7py3s0m0,ResourceId=,Version=0.9.11.0,Architecture=Neutral which have different contents. Please remove one of these packages, or increment current package versions to continue.

The version is unchanged, causing the submission to fail, since we truncate the build number, as the Windows Store requires the 4th component to be 0 (see #5666).

Expected behaviour

Replace the third component in the version number given in AppxManifest.xml with the build number if given. For example if the build number is 1000 and the full original version string would be 1.2.3.1000, change it to 1.2.1000.0. Keep using the original version number in manifest.json.

Change History (6)

comment:1 Changed 2 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 2 years ago by sebastian

  • Description modified (diff)

comment:5 Changed 2 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 11 months ago by abpbot

A commit referencing this issue has landed:
Issue 5668 - Reintroduce buildnumber shifting for edge

Note: See TracTickets for help on using tickets.