Opened 8 months ago

#5677 new change

Update punycode.js

Reported by: sergz Assignee:
Priority: P3 Milestone:
Module: Libadblockplus Keywords:
Cc: fhd, hfiguiere Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

It has been already done in adblockpluschrome, #4350, and it would be useful to do it in libadblockplus as well.

What to change

  • For the sake of simplicity copy punycode.js from adblockpluschrome repository
  • add support of module in convert_js.py
  • put punycode.js at the beginning of library_files list in libadblockplus.gyp because now it supports require mechanism.
  • change how it's used in lib/basedomain.js
  • add tests verifying that the new version still works
  • whatever else is required

Change History (0)

Note: See TracTickets for help on using tickets.