Opened 2 years ago

Closed 3 months ago

#5702 closed change (fixed)

Update core to use standard APIs instead of internal Gecko APIs

Reported by: mjethani Assignee:
Priority: P3 Milestone:
Module: Core Keywords:
Cc: sebastian Blocked By: #7375, #7376, #7380, #7381, #7382
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by trev)

Background

The legacy Gecko extension has been replaced, therefore Adblock Plus core should no longer be using internal Gecko APIs (through polyfills).

What to change

Modify the code in adblockpluscore to use the appropriate standard APIs instead of Cc/Ci/Cr/Cu, making a special compatibility layer unnecessary.

Change History (12)

comment:1 Changed 2 years ago by mjethani

@sebastian, @trev: I've added a minimal description, please update it with more details as necessary.

comment:2 Changed 2 years ago by sebastian

  • Description modified (diff)

comment:3 Changed 2 years ago by trev

  • Priority changed from Unknown to P3
  • Ready set

comment:4 Changed 2 years ago by mjethani

  • Description modified (diff)

@sebastian: I'm assuming you meant through polyfills.

comment:5 Changed 2 years ago by trev

  • Description modified (diff)

comment:6 Changed 22 months ago by fhd

  • Cc trev removed

comment:7 Changed 7 months ago by mjethani

  • Blocked By 7376 added

comment:8 Changed 7 months ago by mjethani

  • Blocked By 7375 added

comment:9 Changed 7 months ago by mjethani

  • Blocked By 7380 added

comment:10 Changed 7 months ago by mjethani

  • Blocked By 7382 added

comment:11 Changed 7 months ago by kzar

  • Blocked By 7381 added

comment:12 Changed 3 months ago by mjethani

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.