Opened 2 years ago

Closed 2 years ago

#5705 closed defect (worksforme)

Adding empty filter list makes toggle unresponsive

Reported by: saroyanm Assignee:
Priority: P2 Milestone:
Module: User-Interface Keywords:
Cc: juliandoucette, greiner Blocked By:
Blocking: #5158 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Replace this text with the Version of your operating system, your exact browser version, the used Adblock Plus version and the enabled Filter lists.

How to reproduce

  1. Run ./test_server.py from inside the adblockplusuirepository
  2. Go to ​http://localhost:5000/new-options.html?#advanced
  3. Click Add a new filter list button
  4. Click Add filter list button
  5. Toggle Adblock Warning Removal List 2 times
  6. Observe

...

Observed behaviour

Toggle stuck and error below is thrown:

Uncaught TypeError: Cannot read property 'replace' of undefined

Expected behaviour

Toggle is not stuck and no unexpected behaviors are observed even if user somehow managed to add empty filter list

Change History (2)

comment:1 Changed 2 years ago by saroyanm

This edge case will be fixed in #5549, but we still need to be sure that user can't add an empty filter and in case he does, we still don't experience unexpected behavior mentioned in this reproduction ticket.

comment:2 Changed 2 years ago by saroyanm

  • Resolution set to worksforme
  • Status changed from new to closed

I couldn't reproduce this by adding filter list without title, seems like the issue was because script in the new-options.js didn't expect filter to be without title and that were causing unexpected behavior, which should cause only specific session(I mean the issue will dissapear the page will be reloaded) and this is no more the case as we have validation.

tl;dr: If we add Filter without title somehow, the URL is shown instead of title and it's issue mentioned here is un-reproducible anymore.

Note: See TracTickets for help on using tickets.