Opened 2 years ago

Last modified 2 years ago

#5731 new defect

AdblockPlusEngine crashes

Reported by: st3fan Assignee:
Priority: P3 Milestone:
Module: Adblock-Plus-for-Internet-Explorer Keywords: crash
Cc: sergz, oleksandr Blocked By:
Blocking: Platform: Internet Explorer
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Adblock Plus version number: 1.6
Browser: Internet Explorer 11; "Enable 64-bit processes for Enhanced Protected Mode" setting is ticked. "Enable Enhanced Protected Mode" setting itself is not ticked, so EPM is disabled.
Computer OS: Windows 10 1607 64-bit
Filter used: EasyList

How to reproduce

Since 14th of September, Adblock Plus plugin keeps crashing on all our PCs that are set up as described above. The crash always seems to happen when a network connection to some *.adblockplus.org domain is established. This can be reproduced as follows. Open IE and browse to a few random websites (open several tabs). Then wait for the next connection to *.adblockplus.org. Straight afterwards the ABP plugin will crash, resulting in the messages and logs mentioned below.

Observed behaviour

The following popup appears in Internet Explorer:
"Adblock Plus Engine for Internet Explorer has stopped working. A problem caused the program to stop working correctly. Please close the program."

The following event log is logged in Event Viewer:
Faulting application name: AdblockPlusEngine.exe, version: 1.6.0.0, time stamp: 0x586bc0f5
Faulting module name: AdblockPlusEngine.exe, version: 1.6.0.0, time stamp: 0x586bc0f5
Exception code: 0xc0000409
Fault offset: 0x00000000002cbad8
Faulting process id: 0x19d0
Faulting application start time: 0x01d32d281be2cded
Faulting application path: C:\Program Files\Adblock Plus for IE\AdblockPlusEngine.exe
Faulting module path: C:\Program Files\Adblock Plus for IE\AdblockPlusEngine.exe
Report Id: e13adc19-33b9-4147-97c1-5e38225f188d
Faulting package full name: %14
Faulting package-relative application ID: %15

The following network connection was established 1 second before ABP crashed:
Network connection detected:
Image: C:\Program Files\Adblock Plus for IE\AdblockPlusEngine.exe
User: xxx
Protocol: tcp
Initiated: true
SourceIsIpv6: false
SourceIp: 192.168.1.77
SourceHostname: xxxxxxx
SourcePort: 57214
SourcePortName:
DestinationIsIpv6: false
DestinationIp: 136.243.58.99
DestinationHostname:
DestinationPort: 443
DestinationPortName: https

Expected behaviour

ABP plugin should not crash.

Change History (6)

comment:1 Changed 2 years ago by mapx

Last edited 2 years ago by mapx (previous) (diff)

comment:2 Changed 2 years ago by mapx

  • Cc sergz oleksandr added

comment:3 Changed 2 years ago by st3fan

Is this really related to https://issues.adblockplus.org/ticket/3412? Ticket 3412 is an old issue. This issue on the other hand started last week only. We have been using ABP for a few months on the affected PCs - this is a new issue in my opinion. We don't use EPM and we also don't use Bing.

FYI, the problem did not occur today. I will re-deploy ABP on a few test machines tomorrow and see how it goes.

comment:4 Changed 2 years ago by oleksandr

  • Component changed from Unknown to Adblock-Plus-for-Internet-Explorer
  • Keywords crash added
  • Priority changed from Unknown to P3

comment:5 Changed 2 years ago by oleksandr

I cannot reproduce the crash. We are in process of updating the AdblockPlusEngine internals, so this could possibly be fixed in the next devbuild.

comment:6 Changed 2 years ago by st3fan

FYI, I have re-deployed ABP to about 20 PCs today and I have not seen this issue again. I will check again tomorrow.

Note: See TracTickets for help on using tickets.