Opened 22 months ago

Closed 21 months ago

Last modified 21 months ago

#5751 closed change (fixed)

Remove the "gecko" build target from buildtools

Reported by: tlucas Assignee: tlucas
Priority: P3 Milestone:
Module: Automation Keywords:
Cc: kzar, sebastian, kvas, fhd, trev Blocked By:
Blocking: #5757, #5836, #5837, #5845 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29562599/

Description (last modified by tlucas)

Background

Starting with Firefox 57, legacy Gecko extensions are no longer supported. Therefore future versions of Adblock Plus will be WebExtensions, the development build has already been switched over to the gecko-webext build. If necessary we can still release emergency updates for the legacy Gecko extension, after support has been removed from buildtools, as we wouldn't update the dependency anyway in this case.

What to change

Remove the buildtools' features for legacy gecko extensions:

  • Remove packagerGecko.py
  • Remove the gecko types and target from build.py
  • Remove support for gecko-style translations from localeTools.py
  • Remove the folder lib
  • Remove install.rdf.tmpl and bootstrap.js.tmpl from templates
  • Remove the gecko target from releaseAutomation.py

Integration notes

Please make sure that every dependent module adheres to the loss of support for .dtd translations.

Attachments (1)

trans_to_json.py (846 bytes) - added by tlucas 22 months ago.

Download all attachments as: .zip

Change History (27)

comment:1 Changed 22 months ago by tlucas

  • Cc fhd added

comment:2 Changed 22 months ago by kzar

  • Cc trev added

comment:3 Changed 22 months ago by kzar

  • Description modified (diff)

comment:4 follow-up: Changed 22 months ago by sebastian

  • Description modified (diff)
  • Summary changed from Remove gecko features from the buildtools to Remove the "gecko" build target from buildtools

Note that sitescripts still imports packagerGecko in order to extract metadata for development builds of legacy Gecko extensions. While the development builds of Adblock Plus have been switched to WebExtensions, we still have following legacy extensions:

  • Element Hiding Helper
  • Customizations for Adblock Plus
  • Diagnostics for Adblock Plus
  • URL Fixer

Those will stop working with Firefox >=57 as well, and we won't update them anymore either. So we can just remove their development builds, along with the related code in sitescripts. This, however, needs to happen before support for legacy Gecko extension is removed from buildtools.

@trev: Can you remove those extensions from the sitescripts.ini on the server?

@tlucas: Can you file a separate issue and remove the related code from sitescripts, first?

Last edited 22 months ago by sebastian (previous) (diff)

comment:5 Changed 22 months ago by tlucas

@sebastian : yes, i have been discussing with vasily how he wanted this to be done (regarding this issue and #5752)

comment:6 Changed 22 months ago by tlucas

  • Blocked By 5757 added

comment:7 Changed 22 months ago by tlucas

@sebastian, @kvas - i would appreciate a hint on where to look for code related to the other gecko extensions mentioned in ticket:5751#comment:4 - i was only able to find related code in web.adblockplus.org (download links)

comment:8 Changed 22 months ago by kzar

  • Blocking 5080 added

comment:9 in reply to: ↑ 4 Changed 22 months ago by trev

Replying to sebastian:

@trev: Can you remove those extensions from the sitescripts.ini on the server?

Not before Firefox 57 is out.

Note that this isn't a blocker as long as the dependency in sitescripts repository isn't updated.

Last edited 22 months ago by trev (previous) (diff)

comment:10 Changed 22 months ago by sebastian

  • Blocking 5535 added; 5080 removed

comment:11 Changed 22 months ago by sebastian

  • Blocked By 5757 removed
  • Blocking 5757 added
  • Priority changed from Unknown to P3
  • Ready set

Until recently the server running sitescripts, always used the latest buildtools. However, since this is no longer true, we need a dependency update anyway, and can just defer it until Firefox 57 is out. Though, I'm not sure how useful development builds for our less popular legacy extensions are, after we already abandoned the developments builds for the legacy Gecko extension of Adblock Plus. Anyway, I updated #5757 accordingly, which as a result is no longer blocking this issue.

comment:12 Changed 22 months ago by kzar

  • Blocking 5535 removed

(Since we've given up automatically generating the resolve paths for now this is no longer blocking #5535.)

comment:13 Changed 22 months ago by tlucas

  • Owner set to tlucas

comment:14 Changed 22 months ago by tlucas

  • Description modified (diff)

Changed 22 months ago by tlucas

comment:15 Changed 22 months ago by tlucas

  • Blocking 5763 added

comment:16 Changed 22 months ago by kzar

(See also #4275 and #4829.)

comment:17 Changed 22 months ago by tlucas

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:18 Changed 22 months ago by tlucas

  • Description modified (diff)

comment:19 Changed 22 months ago by tlucas

  • Description modified (diff)

comment:20 Changed 22 months ago by sebastian

  • Blocking 5836 added

comment:21 Changed 22 months ago by sebastian

  • Blocking 5837 added

comment:22 Changed 22 months ago by sebastian

  • Blocking 5845 added

comment:23 Changed 22 months ago by sebastian

  • Blocking 5763 removed

comment:24 Changed 21 months ago by abpbot

A commit referencing this issue has landed:
Issue 5751 - Removing legacy gecko support

comment:25 Changed 21 months ago by tlucas

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:26 Changed 21 months ago by tlucas

This change introduced a regression, see #5939

Note: See TracTickets for help on using tickets.