Opened 2 years ago

Closed 23 months ago

#5759 closed defect (duplicate)

Error when attempting to show notifications in Opera

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: Core Keywords:
Cc: sebastian, jsonesen Blocked By:
Blocking: Platform: Opera
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 1.13.3.1838
Opera 47 / Windows 10

How to reproduce

  1. Install ABP.
  2. Serve the notification.json request made after install a valid notification. -or-
  3. Add a notification via console.

Observed behaviour

No notification appears and the following error appears in the background page console:

Unchecked runtime.lastError while running notifications.create: Adding buttons to notifications is not supported.
at showNotification (chrome-extension://ldcecbkkoecffmfljeihcmifjjdoepkn/lib/adblockplus.js:1418:28)
at Object.showNext (chrome-extension://ldcecbkkoecffmfljeihcmifjjdoepkn/lib/adblockplus.js:8816:9)
at Object._onDownloadSuccess (chrome-extension://ldcecbkkoecffmfljeihcmifjjdoepkn/lib/adblockplus.js:8637:18)
at XMLHttpRequest.request.addEventListener.event (chrome-extension://ldcecbkkoecffmfljeihcmifjjdoepkn/lib/adblockplus.js:4470:12)

Expected behaviour

The notification to appear and the error to not occur.

Change History (4)

comment:1 Changed 2 years ago by Ross

This is like #5354 when the anti-adblock notification should be triggered. As far as I remember, normal (non-button/question) notifications should work in Opera but do not because of this issue.

Last edited 2 years ago by Ross (previous) (diff)

comment:2 Changed 2 years ago by Ross

  • Summary changed from Error when attempting to open notifications in Opera to Error when attempting to show notifications in Opera

comment:3 Changed 23 months ago by jsonesen

Is this a duplicate of #5354 or should they at least be linked?

Last edited 23 months ago by jsonesen (previous) (diff)

comment:4 Changed 23 months ago by sebastian

  • Cc sebastian jsonesen added
  • Resolution set to duplicate
  • Status changed from new to closed

As Ross pointed out above, #5354 is about the chrome.notifications API not supporting buttons on Opera. This issue is about notifications that aren't even supposed to have buttons causing an error as well. This seems to be because we pass buttons to chrome.notifications.create() even if it is an empty array. But Iagree that this can be merged into #5354.

Note: See TracTickets for help on using tickets.