Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#5766 closed defect (invalid)

Youtube ad on main page is not blocked

Reported by: asmirnov Assignee:
Priority: P2 Milestone:
Module: Libadblockplus-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Android
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Updated libadblockplus (#5556 done), any locale (Robert tested with German(?), Anton with Russian).

How to reproduce

  1. Go to http://m.youtube.com
  2. Make sure you can see "Ad" or " Реклама" text with ad banner shown
  3. Uncheck AA checkbox and retry. Does not help.

...

Observed behaviour

One can see "Ad" or " Реклама" text with ad banner shown.

Expected behaviour

No banners are shown

Attachments (6)

youtube-ad.png (1.1 MB) - added by asmirnov 21 months ago.
screenshot
youtube-ad.txt.zip (9.1 KB) - added by asmirnov 21 months ago.
log file
Снимок экрана 2017-09-25 в 16.30.40.png (1.9 MB) - added by asmirnov 21 months ago.
DOM
Снимок экрана 2017-09-25 в 16.41.05.png (1.2 MB) - added by asmirnov 21 months ago.
div classname seems to be different all the time (circumvention?)
Снимок экрана 2017-09-25 в 16.56.21.png (1.3 MB) - added by asmirnov 21 months ago.
google made it looking as regular search result
device-2017-09-26-164530.png (1.3 MB) - added by asmirnov 21 months ago.
checked fixed

Download all attachments as: .zip

Change History (11)

Changed 21 months ago by asmirnov

screenshot

Changed 21 months ago by asmirnov

log file

comment:1 Changed 21 months ago by asmirnov

  • Ready set

comment:2 Changed 21 months ago by asmirnov

i've checked blocking rules are working, elemhide is working so it seems to be filters issue.
For some reason setting mobile agent in desktop browser (Mozilla/5.0 (Linux; Android 5.0; SM-N9005 Build/LRX21V; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/61.0.3163.98 Mobile Safari/537.36) does not help to reproduce the case on desktop (the ad is not shown) and detect URL to be blocked or element to be hidden for now. To be continued

Last edited 21 months ago by asmirnov (previous) (diff)

Changed 21 months ago by asmirnov

div classname seems to be different all the time (circumvention?)

Changed 21 months ago by asmirnov

google made it looking as regular search result

comment:4 Changed 21 months ago by asmirnov

  • Resolution set to invalid
  • Status changed from new to closed

comment:5 Changed 21 months ago by asmirnov

Reply from Monzta:
"Hi Anton,

This should get rid of them: https://github.com/easylist/easylist/commit/1c12fba53ed1535b7b0c71332746a012c25c3a04

Thanks,
Arthur"

Last edited 21 months ago by asmirnov (previous) (diff)

Changed 21 months ago by asmirnov

checked fixed

Note: See TracTickets for help on using tickets.