Opened 15 months ago

Closed 5 days ago

#5771 closed defect (worksforme)

ABP prevents loading of Edge about:flags page

Reported by: Ross Assignee:
Priority: P2 Milestone:
Module: Platform Keywords:
Cc: sebastian, oleksandr, geo Blocked By:
Blocking: Platform: Edge
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29587555/

Description (last modified by oleksandr)

Environment

ABP 0.9.11.1849
Edge 40 / Windows 10

How to reproduce

  1. Navigate to about:flags in Edge.
  2. Install ABP for Edge.
  3. Navigate to about:flags again in Edge.
  4. Select Edge Menu > Extensions > ABP > Switch slider to off.
  5. Navigate to about:flags in Edge again.

Observed behaviour

with ABP not installed or turned off, the about:flags page loads successfully, with it installed/on, it does not.

Expected behaviour

ABP should not prevent internal browser pages from loading.

Hints for testers

The fix involved changing the subscription mechanism for listening to webRequests on all browsers. Please make sure all the requests types are blockable on all supported browsers.
The bug was also reproducible for other non http/https URLs. Like file:// or viewing PDF inside Edge etc. Please make sure that is fixed as well.

Change History (9)

comment:1 Changed 15 months ago by sebastian

  • Cc oleksandr added
  • Component changed from Core to Platform
  • Priority changed from Unknown to P2
  • Ready set

comment:2 Changed 14 months ago by oleksandr

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 13 months ago by abpbot

A commit referencing this issue has landed:
Issue 5771 - ABP prevents loading of Edge about:flags page

comment:4 Changed 13 months ago by oleksandr

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 13 months ago by abpbot

comment:6 Changed 13 months ago by kzar

  • Resolution fixed deleted
  • Status changed from closed to reopened

It looks like this change at least partially broke WebSocket blocking (#6052) so I've reverted that fix.

Version 0, edited 13 months ago by kzar (next)

comment:7 Changed 7 days ago by sebastian

  • Cc geo added

According to Geo, blocking of WebSockets doesn't work on Microsoft Edge regardless of this change. Can you confirm that WebSocket connections cannot be intercepted through the webRequest API in Microsoft Edge, and if so file a Microsoft Edge bug?

comment:8 Changed 6 days ago by Ross

The about:flags part of this ticket looks to no longer be an issue.

ABP 0.9.11.2206
Edge 42.17134.1.0 / EdgeHTML 17.17134 / Windows 10 (1803)

comment:9 Changed 5 days ago by sebastian

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.