Opened 2 years ago

Closed 2 years ago

#5783 closed defect (rejected)

Warning - 'stringByAddingPercentEscapesUsingEncoding:' is deprecated.

Reported by: CraftyDeano Assignee: CraftyDeano
Priority: Unknown Milestone:
Module: Adblock-Plus-for-iOS/macOS Keywords:
Cc: ashephard, dzhang Blocked By:
Blocking: Platform: iOS
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29556618/

Description

Building currently generates the following warning:

/adblockplussafariios/AdblockPlusSafari/NSString+AdblockPlus.m:43:24: 'stringByAddingPercentEscapesUsingEncoding:' is deprecated: first deprecated in iOS 9.0 - Use -stringByAddingPercentEncodingWithAllowedCharacters: instead, which always uses the recommended UTF-8 encoding, and which encodes for a specific URL component or subcomponent since each URL component or subcomponent has different rules for what characters are valid.

Will migrate away from the deprecated API to its successor.

Change History (3)

comment:1 Changed 2 years ago by CraftyDeano

  • Status changed from new to reviewing

comment:2 Changed 2 years ago by CraftyDeano

  • Review URL(s) modified (diff)

comment:3 Changed 2 years ago by CraftyDeano

  • Resolution set to rejected
  • Status changed from reviewing to closed

Dupe of #5789

Note: See TracTickets for help on using tickets.