Opened 2 years ago

Closed 2 years ago

#5793 closed defect (rejected)

Analysis Issue - Potential null dereference

Reported by: CraftyDeano Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-iOS/macOS Keywords:
Cc: ashephard, dzhang Blocked By:
Blocking: Platform: iOS
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Xcode static analyser highlights the following issues:

Assertion: Potential null dereference.  According to coding standards in 'Creating and Returning NSError Objects' the parameter may be null
File: adblockplussafariios/AdblockPlusSafari/AdblockPlus+ActivityChecking.m:69

Assertion: Potential null dereference.  According to coding standards in 'Creating and Returning NSError Objects' the parameter may be null
File: adblockplussafariios/AdblockPlusSafari/AdblockPlus+ActivityChecking.m:63

Add checks to error to ensure its not equal to NULL as per Apples Documentation.

Change History (1)

comment:1 Changed 2 years ago by CraftyDeano

  • Resolution set to rejected
  • Status changed from new to closed

Duplicate of #5792

Note: See TracTickets for help on using tickets.