#5802 closed defect (fixed)

Unexpected behavior on fresh Adblock Plus installaation

Reported by: saroyanm Assignee: saroyanm
Priority: P1 Milestone:
Module: User-Interface Keywords:
Cc: greiner, wspee Blocked By:
Blocking: #5158 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29557727/

Description (last modified by saroyanm)

Environment

Chrome

How to reproduce

  1. Build and load Adblock Plus with the new options page bundled as described here
  2. Open settings page
  3. Go to Advanced page
  4. Observe My filter list section
  5. Go to Whitelisted websites
  6. Add new website (ex.: google.com)
  7. Observe
  8. Reload the page
  9. Observe

Observed behaviour

Step #4: It shows textarea with no control button
Step #6: Nothing happened

Expected behaviour

Step #4: Shows Learn how to create filter list view
Step #6: New website is added

Note

Step #9: On this step things start to work as expected, all this unexpected behavior might be caused by "User"(~user~#) filter list not being initialized.

Change History (5)

comment:1 Changed 22 months ago by saroyanm

  • Description modified (diff)

comment:2 Changed 22 months ago by saroyanm

  • Owner set to saroyanm

comment:3 Changed 22 months ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 22 months ago by abpbot

A commit referencing this issue has landed:
Issue 5802 - Handle custom subscription creation

comment:5 Changed 22 months ago by saroyanm

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.