Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#581 closed defect (fixed)

Element hiding and collapsing doesn't work within inline frames on Chrome

Reported by: sebastian Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-1.8.4-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5666188336037888
http://codereview.adblockplus.org/5664713014771712

Description (last modified by sebastian)

Environment

Reproduced in Chrome 34 and 30 on Linux and Windows.

How to reproduce

Go to any web page that shows ads in frames that aren't loaded by their src attribute but constructed with JavaScript.

For example: http://www.chip.de/downloads/Adblock-Plus-fuer-Firefox_22437623.html

Observed behaviour

You see placeholders for two ads whose web request has been blocked by Adblock Plus. This is because Chrome doesn't run content scripts for inline frames, hence the element collapsing code doesn't run. Element hiding won't work for the same reason too.

Expected behaviour

Placeholders for blocked elements must be hidden and element hiding must be applied in all frames.

Change History (9)

comment:1 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by sebastian

  • Description modified (diff)

comment:3 Changed 5 years ago by sebastian

Last edited 5 years ago by sebastian (previous) (diff)

comment:4 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)

comment:6 Changed 5 years ago by sebastian

The patch also fixes #659.

comment:7 Changed 5 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

Implemented workaround for older Chrome versions.

https://hg.adblockplus.org/adblockpluschrome/rev/191f69afc9d6

Last edited 5 years ago by sebastian (previous) (diff)

comment:8 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next

comment:9 Changed 5 years ago by sebastian

  • Description modified (diff)
  • Platform set to Unknown
  • Summary changed from Element hiding and collapsing doesn't work in anonymous frames on Chrome to Element hiding and collapsing doesn't work within inline frames on Chrome
Note: See TracTickets for help on using tickets.