Opened 3 months ago

Closed 2 months ago

Last modified 2 months ago

#5816 closed defect (worksforme)

Filter subscriptions are lost on APK reinstall

Reported by: rscott Assignee:
Priority: Unknown Milestone: Adblock-Plus-for-Samsung-Browser-1.1.2
Module: Adblock-Plus-for-Samsung-Browser Keywords:
Cc: vickyyu Blocked By:
Blocking: Platform: Samsung Browser
Ready: no Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

Description

Version: adblockplussbrowser-debug.apk (1.1.2 candidate; md5sum: d165a476e198eb804a4ec4ff071f474e)
Samsung Internet version: 5.4.02.3
Platform: Pixel/Android 8.0

Reproduction:

  • Install the APK.
  • Change the following preferences:
    • Configure your filter lists > enable "Deutsch".
    • More blocking options > enable "Disable anti-ad blocking messages".
    • Add the site "slashdot.org" to the whitelist.
    • Configure automatic updates > Always.
    • Uncheck "Allow some nonintrusive advertising".
  • Install the APK again (without uninstalling).
  • Observe:
    • Of the language-based filters, only English is enabled. (reset)
    • Under "More blocking options", no filters are enabled. (reset)
    • Under "Whitelisted websites", "slashdot.org" is still present. (preserved)
    • "Configure automatic updates" is still set to Always. (preserved)
    • "Allow some nonintrusive advertising" is still unset. (preserved)


Expected result:

  • Filter lists should be preserved after an APK reinstall.

Additional information:

This is a regression since the previous release.

Change History (4)

comment:1 Changed 3 months ago by vickyyu

  • Cc vickyyu added

comment:2 Changed 2 months ago by jwangenheim

I was not able to reproduce this issue on Nexus 5X with Android 8 and Samsung Galaxy S5 with Android 6.0.1

comment:3 Changed 2 months ago by rscott

  • Resolution set to worksforme
  • Status changed from new to closed

Truly bizarre -- this is reproduceable consistently on my Pixel, but not on any other device I've tried, including an identical Pixel from TestObject. Marking "WFM".

comment:4 Changed 2 months ago by rscott

  • Verified working set
Note: See TracTickets for help on using tickets.