Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5837 closed change (fixed)

Update buildtools and adblockplusui dependencies for locale changes

Reported by: sebastian Assignee: sebasian
Priority: P2 Milestone:
Module: Platform Keywords:
Cc: kzar, tlucas Blocked By: #5751, #5763, #5836, #5845
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29573922

Description (last modified by sebastian)

Background

  • #5763 changed the expected contents of the _locales directory, i.e. es_MX instead of es_419.
  • #5751 and #5836 change the way translations are imported. Therefore the buildtools and adblockplusui dependencies need to be updated at the same time.
  • #5845 renames the gecko-webext build target to gecko.

The buildtools dependency update also fixes the release automation (#5736) and compatibility with the Crowdin API (#5777 and #5815).

What to change

  • Update the dependencies file to refer to revisions of buildtools after #5763 and #5751 landed.
  • Update the dependencies file to refer to revisions of adblockplusui after #5836 landed.
  • Rename _locales/es_419 to _locales/es_MX.
  • Rename metadata.gecko-webext to metadata.gecko.
  • Change the import_locales section in metadata.chrome and metadata.gecko to import strings as = * instead of = =*.

Hints for testers

Make sure that all translations are picked up if running the browser in the respective language. Note that some languages are only supported on either Chrome or Firefox.

Change History (16)

comment:1 Changed 2 years ago by sebastian

  • Description modified (diff)

comment:2 Changed 2 years ago by sebastian

  • Summary changed from Update buildtools dependency and adapt for locale changes to Update buildtools and adblockplusui dependencies for locale changes

comment:3 Changed 2 years ago by sebastian

  • Blocked By 5845 added
  • Description modified (diff)

comment:4 Changed 2 years ago by sebastian

  • Description modified (diff)

comment:5 Changed 2 years ago by tlucas

  • Description modified (diff)

comment:6 Changed 2 years ago by kzar

  • Blocked By 5535 added
  • Description modified (diff)

I've added some quick integration notes for the webpack changes as Sebastian requested in IRC, since I have to leave now that's all I have time for but I can add more information later if necessary.

comment:7 in reply to: ↑ description Changed 2 years ago by sebastian

  • Cc kzar added

Replying to kzar:

and the description of #5080 which should possibly be marked as a duplicate of this issue.

If possible, I would like to keep #5080 separate, and only do the minimal changes necessary when updating the buildtools dependency. This dependency update is already becoming complex enough.

comment:8 Changed 2 years ago by sebastian

  • Summary changed from Update buildtools and adblockplusui dependencies for locale changes to Update buildtools+adblockplusui dependencies for locale changes + webpack

comment:9 Changed 2 years ago by sebastian

  • Blocked By 5535 removed
  • Cc tlucas added
  • Description modified (diff)
  • Summary changed from Update buildtools+adblockplusui dependencies for locale changes + webpack to Update buildtools and adblockplusui dependencies for locale changes

I removed the webpack stuff from this dependency update, see ticket:5535#comment:39.

Last edited 2 years ago by sebastian (previous) (diff)

comment:10 Changed 2 years ago by tlucas

  • Description modified (diff)

comment:11 Changed 2 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:12 Changed 2 years ago by sebastian

  • Description modified (diff)

comment:13 Changed 2 years ago by sebastian

  • Description modified (diff)

comment:15 Changed 2 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:16 Changed 2 years ago by sebastian

  • Description modified (diff)
Note: See TracTickets for help on using tickets.