Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5842 closed defect (fixed)

Spanish and Vietnamese filter lists string assignment missing in the options page

Reported by: saroyanm Assignee:
Priority: P3 Milestone:
Module: User-Interface Keywords:
Cc: greiner, sebastian, wspee Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29567856/
https://codereview.adblockplus.org/29572786/

Description (last modified by saroyanm)

Environment

Firefox

How to reproduce

  1. Apply patch from here to adblockpluschrome repository
  2. Build project using python build.py -t gecko-webext devenv
  3. Load extension from about:debugging
  4. Navigate to the options page
  5. Click on "Add a language" button
  6. Observe

Observed behaviour

https://easylist-downloads.adblockplus.org/abpvn+easylist.txt and https://easylist-downloads.adblockplus.org/easylistspanish+easylist.txt are being shown in the dialog

Expected behaviour

Vietnamese and Spanish are shown accordingly.

Note

This is stopgap solution until this issue is resolved and all languages are updated accordingly.

Change History (17)

comment:1 Changed 2 years ago by saroyanm

  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set

comment:2 Changed 2 years ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 2 years ago by saroyanm

  • Owner set to saroyanm

comment:4 Changed 2 years ago by abpbot

comment:5 Changed 2 years ago by saroyanm

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 follow-up: Changed 2 years ago by sebastian

Since translations have already been requested, and we are in string freeze now, can we please revert this change, and land it after we don't need to update the dependency in adblockpluschrome anymore, for the upcoming release?

comment:7 Changed 2 years ago by sebastian

  • Cc sebastian added

comment:8 in reply to: ↑ 6 Changed 2 years ago by saroyanm

  • Cc wspee added

Replying to sebastian:

Since translations have already been requested, and we are in string freeze now, can we please revert this change, and land it after we don't need to update the dependency in adblockpluschrome anymore, for the upcoming release?

You want me to revert this change from the adblockplusui repository completely and do not introduce any string changes in adblockplusui (while in string freeze), or keep updating strings in adblockplusui (if needed), but stop updating dependencies in adblockpluschrome ?

comment:9 follow-up: Changed 2 years ago by sebastian

We cannot stop updating the dependency in adblockpluschrome, yet. We at least have to update it one more time, when the translations arrive. But also need to be able to do fixes if necessary to the new options page, if we find any bugs before the release.

So I suggest to revert this change from adblockplusui and don't land any changes that add new strings, until we don't need to update the dependency in adblockpluschrome anymore.

comment:10 in reply to: ↑ 9 Changed 2 years ago by saroyanm

Replying to sebastian:

We cannot stop updating the dependency in adblockpluschrome, yet. We at least have to update it one more time, when the translations arrive. But also need to be able to do fixes if necessary to the new options page, if we find any bugs before the release.

So I suggest to revert this change from adblockplusui and don't land any changes that add new strings, until we don't need to update the dependency in adblockpluschrome anymore.

Noted, that's unfortunate, I'll revert the strings back tomorrow in case no more arguments against, or if it's not urgently needs to be done until tomorrow.

comment:11 Changed 2 years ago by saroyanm

  • Resolution fixed deleted
  • Status changed from closed to reopened

The changes are reverted.
This issue is reopen again, as the strings added here are added after the string freeze.

comment:12 Changed 2 years ago by saroyanm

  • Owner saroyanm deleted

comment:13 follow-up: Changed 2 years ago by sebastian

I think you have to revert the changes to subscription.xml as well. Otherwise, the new subscriptions show up in the UI, but there is no string to show at all, right?

comment:14 in reply to: ↑ 13 Changed 2 years ago by saroyanm

Replying to sebastian:

I think you have to revert the changes to subscription.xml as well. Otherwise, the new subscriptions show up in the UI, but there is no string to show at all, right?

subscription.xml in the UI is just for test. I think it should stay and reflect actual state of the options page.

We are using subscription.xml from adblockpluscore in the production.

comment:15 Changed 2 years ago by abpbot

comment:16 Changed 2 years ago by saroyanm

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:17 Changed 2 years ago by saroyanm

  • Review URL(s) modified (diff)
Note: See TracTickets for help on using tickets.