Opened 3 years ago

Closed 3 years ago

#5860 closed defect (fixed)

options page is broken in test enviroment

Reported by: saroyanm Assignee: saroyanm
Priority: P2 Milestone:
Module: User-Interface Keywords:
Cc: greiner, sebastian Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29574648/

Description

Environment

All browsers

How to reproduce

  1. Clone adblockplusui repository
  2. Run test enviroment
  3. Open desktop-options.html
  4. Observe

Observed behaviour

The strings are not loaded and current errors are thrown:

common.js:146 GET http://127.0.0.1:5000/locale/en-US/common.json 404 (File not found)
common.js:146 GET http://127.0.0.1:5000/locale/en-US/desktop-options.json 404 (File not found)

Expected behaviour

Strings are loaded, no errors are thrown

Change History (5)

comment:1 Changed 3 years ago by saroyanm

  • Owner set to saroyanm

Seems like it's caused by latest change in #5836

comment:2 Changed 3 years ago by sebastian

Right, this code in ext/common.js needs to be changed:

  chrome.i18n = {
    getUILanguage()
    {
      return locales[0].replace(/_/g, "-");
    },

To:

  chrome.i18n = {
    getUILanguage()
    {
      return locales[0];
    },

I could submit a patch, but I assume you are already on it, as you assigned the issue to yourself.

Version 0, edited 3 years ago by sebastian (next)

comment:3 Changed 3 years ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

Sorry, I forgot to add the review here. I Will address your comments in the review later today.

comment:4 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 5860 - Fixed broken options page in the test enviroment

comment:5 Changed 3 years ago by saroyanm

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.