Opened 2 years ago

Closed 3 months ago

#5861 closed defect (worksforme)

Fix missing locale errors in the options page test enviroment

Reported by: saroyanm Assignee:
Priority: P4 Milestone:
Module: User-Interface Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by saroyanm)

Environment

All browsers

How to reproduce

  1. Clone adblockplusui repository
  2. Run test enviroment
  3. Open desktop-options.html
  4. Observe

Observed behaviour

The strings are not loaded and current errors are thrown:

common.js:146 GET http://127.0.0.1:5000/locale/en/common.json 404 (File not found)
common.js:146 GET http://127.0.0.1:5000/locale/en/desktop-options.json 404 (File not found)

Expected behaviour

  • Strings are loaded, no errors are thrown
  • Ideally we would like to also throw error when requested string is not available (ex. Unknown localization message $msgId$).

Change History (3)

comment:1 Changed 2 years ago by saroyanm

The issue here seems to be xhr error handling, while it seems like error handling here is tricky maybe we can use fetch API.

I haven't make it part of #5860 intentionally as the priority of this issue is lower than the other one.

comment:2 Changed 2 years ago by saroyanm

  • Description modified (diff)

comment:3 Changed 3 months ago by greiner

  • Resolution set to worksforme
  • Status changed from new to closed

Closing this ticket because we have since added translation file linting to ensure those files are valid (see ui#82). Furthermore, any errors relating to missing translation files are either expected (i.e. we don't have translations for a given file yet) or an actual error (e.g. we forgot to remove the reference to a translation file that no longer exists).

Note: See TracTickets for help on using tickets.