#5862 closed defect (fixed)

CMS unexpected page conflicts caused by additional-paths

Reported by: kvas Assignee: kvas
Priority: P2 Milestone:
Module: Sitescripts Keywords:
Cc: juliandoucette, ire Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29586663/

Description (last modified by kvas)

Environment

CMS after revision de35489c1eb2 (this is a problem with a feature introduced by #5336).

How to reproduce

  1. Create a website with an empty index.html in pages/ directory, empty default.tmpl in templates/ directory and the following content in settings.ini:

[general]
defaultlocale = en
defaultpage = index

  1. Create another website in a subdirectory parent-website with an empty index.md in parent-website/pages/. Copy settings.ini into parent-website.
  1. Make the main website inherit from parent website: add the following to settings.ini of the main website:

[paths]
additional-paths=parent-website

  1. Run CMS test server in the directory of the main website and go to http://localhost:5000/.

Observed behaviour

Internal server error with the following message: "The requested page conflicts with another page".

Expected behaviour

The browser should display an empty page. index.html from the main website should take priority over index.md from the parent website and no conflict should occur.

The same thing should apply for all pages. Pages from the main website should always take priority over pages from additional-paths and pages from additional paths listed earlier in the list should take priority over the pages from later additional paths. This is already the case if the source files of the page have the same extension in both directories but it should also work if they have different extensions.

Change History (7)

comment:1 Changed 23 months ago by kvas

  • Description modified (diff)

comment:2 Changed 23 months ago by kvas

  • Owner set to kvas
  • Priority changed from Unknown to P2

comment:3 Changed 23 months ago by kvas

  • Ready set

comment:4 Changed 22 months ago by kvas

  • Description modified (diff)

comment:5 Changed 22 months ago by kvas

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 22 months ago by abpbot

A commit referencing this issue has landed:
Fixes 5862 - Prevent page conflicts caused by additional-paths

comment:7 Changed 22 months ago by kvas

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.