#5867 closed defect (invalid)

Firefox for Android: custom filters gone in ABP FF extension

Reported by: tibitts Assignee:
Priority: Unknown Milestone:
Module: User-Interface Keywords:
Cc: mjethani, mapx, saroyanm, greiner Blocked By:
Blocking: Platform: Firefox Mobile
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Android 8, FF 57.0 b7, ABP FF webextension, development build 2.99.0.1881 beta

How to reproduce

In FF for Android:
Menu button - Add-ons - Adblock Plus - Options

Observed behaviour

There's been an overhaul of the Options UI recently. Now only filter subscriptions are left, the custom filters UI is gone from the Options.
Custom filters were available in an earlier version already.

Expected behaviour

Custom filters UI should be visible underneath Options.

Change History (3)

comment:1 Changed 23 months ago by mapx

  • Cc mjethani mapx added

comment:2 Changed 23 months ago by saroyanm

  • Cc saroyanm added

comment:3 Changed 23 months ago by greiner

  • Cc greiner added
  • Component changed from Unknown to User-Interface
  • Resolution set to invalid
  • Status changed from new to closed

I think the UI you're referring to is the one we included in initial Web Extension builds. Those builds included the Chrome desktop version of the options page and was not meant to be used for mobile. It was only in there because we didn't have a mobile version ready yet.

The options page that's currently used in Firefox for Mobile is based on the previous options page which didn't offer any UI for custom filters either. Therefore we think it's a good initial version for the first Web Extension release we're currently working on.

Our goal is to eventually make the new desktop options page responsive enough so that we can reuse it for Firefox Mobile at which point it should expose the same features as the desktop version - including a UI to deal with custom filters.

Note: See TracTickets for help on using tickets.