Opened 2 years ago

Closed 2 years ago

#5874 closed change (fixed)

Strings blocked by string freeze

Reported by: saroyanm Assignee: saroyanm
Priority: P2 Milestone:
Module: User-Interface Keywords: options-page
Cc: wspee, jeen, sebastian, greiner, Shikitita, ire Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29584714/

Description (last modified by saroyanm)

Background

Because of the string freeze we can't add all the missing strings to the new options page on this stage, this ticket meant to keep track on all of them for the time of the string freeze

What to change

  • All string changes outlined here
  • Determine all strings that don't match the strings specified in the specification(Note: point above overrides current strings in master branch)

Note!

We currently are in the String freeze and we can't push this strings.

Change History (11)

comment:1 Changed 2 years ago by saroyanm

  • Cc sebastian greiner added
  • Description modified (diff)

I will collect all the strings that are blocked by the string freeze here in order to keep track of all of them, meanwhile I will try to find workarounds to be able to improve layout and important changes without touching strings.

comment:2 Changed 2 years ago by saroyanm

  • Description modified (diff)

comment:3 Changed 2 years ago by saroyanm

  • Cc Shikitita ire added

Tamara determined strings that doesn't match the one specified in the specification, I'd like to prepare a patch that covers all the missmatching strings (she already have translations ready for them), the only problem is that they are not yet in the crowdin. I'll prepare a review here that will reflect current state of the specification strings and keep it updated.

@Sebastian: Can you please let me know until when we will have the String freeze and whether it will be possible to push the changes before the release ? (After that Tamara will be able to update miss-matching strings in the crowdin with professional translation from the agency)

Note: I'll do my best to have the strings ready early next week and reviewed.

comment:4 Changed 2 years ago by saroyanm

  • Description modified (diff)

comment:5 Changed 2 years ago by saroyanm

  • Owner set to saroyanm

comment:6 Changed 2 years ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:7 follow-up: Changed 2 years ago by sebastian

The problem is if we keep changing/adding strings, the translations will never catch up. So I think we should not touch the strings anymore, until the release. But as far as I understand you we'd already have translations (from the agencies) for these new/changed strings?

comment:8 in reply to: ↑ 7 ; follow-up: Changed 2 years ago by saroyanm

Replying to sebastian:

But as far as I understand you we'd already have translations (from the agencies) for these new/changed strings?

Yes, Tamara has translations from the translation agencies, they just don't match the strings as they are in the Crowdin now (that why she can't update them), this review meant to fix that issue and add missing strings(for which she has translations as well, yet unreviewed), Tamara is reviewing now them(translations) and she wish/planing to have them ready, reviewed and updated in the crowdin before the release. Hopefully this changes will be pushed as well, so we will have this strings translated before the release.

comment:9 in reply to: ↑ 8 Changed 2 years ago by saroyanm

Replying to saroyanm:

Replying to sebastian:

But as far as I understand you we'd already have translations (from the agencies) for these new/changed strings?

Yes, Tamara has translations from the translation agencies, they just don't match the strings as they are in the Crowdin now (that why she can't update them), this review meant to fix that issue and add missing strings(for which she has translations as well, yet unreviewed), Tamara is reviewing now them(translations) and she wish/planing to have them ready, reviewed and updated in the crowdin before the release. Hopefully this changes will be pushed as well, so we will have this strings translated before the release.

This changes are almost ready, I will be able to push them tomorrow, Tamara will try to update all crowdin translations by the end of this week.
I'll suggest to push this strings Sebastian, in order to have complete translation for the launch, considering the fact that Tamara already has translations.

Unless we are not planing to launch this week. Otherwise I'll have to hold this back.

Last edited 2 years ago by saroyanm (previous) (diff)

comment:10 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 5874 - Sync strings with translations from the agencies

comment:11 Changed 2 years ago by saroyanm

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.