Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#5877 closed defect (fixed)

First run page is missing some text

Reported by: Ross Assignee: tlucas
Priority: P1 Milestone:
Module: Automation Keywords:
Cc: sebastian, saroyanm, greiner, mjethani, kzar, wspee, tlucas Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29588949

Description (last modified by kzar)

Environment

ABP 2.99.0.1889beta
Firefox 57 / Windows 10

Also

Firefox 57 Android

Also

Firefox 56.0, Debian Buster, Adblock Plus debuild #1895

How to reproduce

  1. Ensure previous extension data is cleared so first run page appears.
  2. Install build.

Observed behaviour

The first run page is missing some (but not all) texts. For example the text of the donate button. Specifically these strings are missing:

firstRun_share_headline
firstRun_donate
firstRun_donate_label
firstRun_share
firstRun_contributor_credits

Expected behaviour

The first run page to display correctly / not be missing text

Notes

Attachments (1)

5877-FirstRunPageText.png (83.7 KB) - added by Ross 22 months ago.

Download all attachments as: .zip

Change History (19)

Changed 22 months ago by Ross

comment:1 Changed 22 months ago by sebastian

  • Cc saroyanm greiner mjethani added

I can reproduce this, both on Firefox and Chrome, when installing the development build from AMO or the CWS. However, I cannot reproduce it when building the extension myself, which is weird and makes it difficult to debug.

comment:2 Changed 22 months ago by saroyanm

  • Priority changed from Unknown to P2
  • Ready set

So far I only can say that it was broken in between Version 2.99.0.1879beta and Version 2.99.0.1881beta builds. Trying to find out which exact change caused this..

In between October 10-12

comment:3 follow-up: Changed 22 months ago by sebastian

Well, Ross and I can also reproduce it with *.1889 from AMO and the CWS.

comment:4 in reply to: ↑ 3 Changed 22 months ago by saroyanm

Replying to sebastian:

Well, Ross and I can also reproduce it with *.1889 from AMO and the CWS.

I meant to say that build *.1879 is not broken(FRP strings are there), while *.1880 and next builds look to be broken.

Last edited 22 months ago by saroyanm (previous) (diff)

comment:5 Changed 22 months ago by saroyanm

  • Cc kzar wspee tlucas added
  • Component changed from User-Interface to Build-and-Release-Tools
  • Priority changed from P2 to Unknown
  • Ready unset

I think this issue somehow connected with buildtools, I can confirm that the strings that are missing do exist in the adblockplusui firstRun.json dependency version.

Note: Also the project built locally and the one available online are missing different strings (This is very odd to me).

@Buildtool team can you please have a look, because I'm having hard time of finding what exactly cause the issue. Also the issue started to appear after the current change.

I think we should fix this before the release.

comment:6 follow-up: Changed 22 months ago by kzar

(Could possibly be related to #5916, but I've not looked into it yet.)

comment:7 in reply to: ↑ 6 ; follow-up: Changed 22 months ago by tlucas

I was able to recreate this using the official dev builds, but i could not recreate this using packages generated locally - just like Sebastian.

However, i managed to create a diff between the two packages - There are only additions, only affecting messages.json files, all additions appear to affect stringIDs with the prefix "firstRun", some locales have more additions then others.

(here's a full list, couldn't think of anything better to distribute this: https://codereview.adblockplus.org/29587789/ )

Replying to kzar:

(Could possibly be related to #5916, but I've not looked into it yet.)

This might be true

comment:8 in reply to: ↑ 7 Changed 22 months ago by saroyanm

Replying to tlucas:

I was able to recreate this using the official dev builds, but i could not recreate this using packages generated locally - just like Sebastian.

As I mentioned above, package generated locally misses different strings. While the packaged that's available online missed for example string from Donation button. The package generated locally has the string for "Donation" button, but misses Adblock Browser promotion strings, like Get Adblock Browser here.

comment:9 Changed 22 months ago by kzar

  • Description modified (diff)

I can also reproduce this, Tristan and I are investigating.

comment:10 Changed 22 months ago by kzar

  • Description modified (diff)

(here's a full list, couldn't think of anything better to distribute this: ​https://codereview.adblockplus.org/29587789/ )

I also also reproduce those differences, so the question is what caused them.

comment:11 Changed 22 months ago by kzar

  • Description modified (diff)

comment:12 Changed 22 months ago by kzar

  • Description modified (diff)

comment:13 Changed 22 months ago by tlucas

  • Owner set to tlucas

comment:14 Changed 22 months ago by kzar

  • Priority changed from Unknown to P1
  • Ready set

comment:15 Changed 22 months ago by tlucas

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:16 Changed 22 months ago by abpbot

A commit referencing this issue has landed:
Issue 5877 - Account for random locale processing order

comment:17 Changed 22 months ago by tlucas

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:18 Changed 22 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. All strings now appear correctly on the first run page.

ABP 1.13.4.1903
Chrome 49 / 62 / Windows 10
Opera 36 / 48 / Windows 10

ABP 2.99.0.1902beta
Firefox 50 / 57 / Windows 10

Note: See TracTickets for help on using tickets.