Opened 2 years ago

Closed 3 months ago

#5878 closed defect (duplicate)

Filter list update times are not displaying correctly

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: User-Interface Keywords: options-page
Cc: sebastian, greiner, saroyanm, wspee Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by greiner)

Environment

ABP 2.99.0.1889beta
Firefox 57 / Windows 10

(Also occurs on Firefox 57 Android)

How to reproduce

  1. Install build.
  2. Add a few filter lists.
  3. Leave the browser for awhile.

Observed behaviour

The only text seen in the Last update column is "Just now" and "hours ago".

Expected behaviour

The text to accurately display the length of time since last update ("Just now" -> "2 hours ago" -> "3 days ago" etc.

What to change

See ui#223.

Attachments (1)

5878-FilterListLastUpdateText.png (71.8 KB) - added by Ross 2 years ago.

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by Ross

comment:1 Changed 2 years ago by sebastian

  • Cc greiner saroyanm wspee added

comment:2 Changed 2 years ago by saroyanm

I think you should also see "minutes ago" and Date(DD MMM YYYY).
Well spotted, this was decided in order to simplify the implementation, but we forgot to update the specs, I've created an issue for that -> https://bitbucket.org/adblockplus/spec/issues/95/

comment:3 follow-up: Changed 2 years ago by saroyanm

Ross can you also please add me to CC to all options page related issues you will or have noticed notice.

comment:4 Changed 2 years ago by saroyanm

  • Keywords options-page added

comment:5 in reply to: ↑ 3 Changed 2 years ago by Ross

Replying to saroyanm:

Ross can you also please add me to CC to all options page related issues you will or have noticed notice.

Yes I will do. I have a feedback sheet for the options page soon too.

comment:6 Changed 14 months ago by greiner

  • Description modified (diff)

Added link to GitLab issue.

comment:7 Changed 3 months ago by greiner

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this ticket in favor of ui#223.

Note: See TracTickets for help on using tickets.