Opened 2 years ago

Closed 3 months ago

#5879 closed defect (duplicate)

Acceptable Ads radio button selection jumps around

Reported by: Ross Assignee:
Priority: P4 Milestone:
Module: User-Interface Keywords: options-page
Cc: sebastian, greiner, saroyanm, wspee Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

ABP 2.99.0.1889beta
Firefox 57 / Windows 10

How to reproduce

  1. Open ABP Settings.
  2. Leave the settings open for awhile?
  3. Select various AA options in the General tab.

Observed behaviour

The radio option selection flickers between even non-selected options before settling on the option the user selected. This doesn't occur all the time, but enough to be noticable. See attached video.

Expected behaviour

To behave like normal radio buttons (de-select one, select another).

Attachments (1)

5879-AAButtons.mp4 (3.6 MB) - added by Ross 2 years ago.

Download all attachments as: .zip

Change History (9)

Changed 2 years ago by Ross

comment:1 Changed 2 years ago by Ross

  • Summary changed from Acceptable Ad radio button selection jumps around to Acceptable Ads radio button selection jumps around

comment:2 Changed 2 years ago by sebastian

  • Cc greiner saroyanm wspee added

comment:3 Changed 2 years ago by saroyanm

Short terms: Acceptable Ads(AA), Privacy Friendly Acceptable Ads(PFAA)

Yes, this one is a little bit tricky to handle, we do update the selection to reflect the current state:

  • Block all ads (no AA and no PFAA)
  • Allow some nonintrusive ads (AA (but no/and) PFAA)
  • Allow only nonintrusive ads that are privacy-friendly (PFAA but no AA)

Click on each radio button makes flickering effect because we have several async actions assigned to the selection. For example click on Allow only nonintrusive ads that are privacy-friendly removes Allow some nonintrusive ads and add Allow only nonintrusive ads that are privacy-friendly, meanwhile it may jumps to Block All Ads, because we can have situation when there is no AA and PFAA until both actions succeed.

I agree that the flickering is annoying. We will launch new version soon, where we will replace Radio buttons with checkboxes. There we might have similar issue.

Anyway I'll try to think about how to make this less annoying, but I can think about solution right now that will eliminate flickering completely, though maybe with checkboxes it might be easier to handle.

comment:4 Changed 2 years ago by saroyanm

  • Priority changed from Unknown to P4
  • Ready set

comment:5 Changed 2 years ago by saroyanm

  • Keywords options-page added

comment:6 Changed 2 years ago by Ross

Okay. That makes perfect sense. Another solution could be to cover that container with an overlay element with a spinner (or something) until it's "done".

comment:7 Changed 3 months ago by greiner

@saroyanm Has there been any progress on this? It'd be great if we could create a GitLab issue for this, in case it still occurs, so that we can close this ticket.

comment:8 Changed 3 months ago by saroyanm

  • Resolution set to duplicate
  • Status changed from new to closed

Can reproduce this one, but created this -> https://gitlab.com/eyeo/adblockplus/abpui/adblockplusui/issues/581

Those are probably related. Resolving this as a duplicate.

Note: See TracTickets for help on using tickets.