Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#5904 closed defect (fixed)

The code in include.preload.js is being run twice

Reported by: kzar Assignee: kzar
Priority: P1 Milestone: Adblock-Plus-3.0-for-Firefox
Module: Platform Keywords:
Cc: mjethani, sebastian Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29587645/

Description

Environment

Chrome 62, Debian Buster, Adblock Plus devbuild built from 129566c42ebc.

How to reproduce

  1. Add console.log("uh oh"); to the top of adblockpluschrome/include.preload.js
  2. Rebuilt the extension
  3. Browse to https://news.ycombinator.com/

Observed behaviour

"uh oh" appears twice in the console per page load.

Expected behaviour

"uh oh" should only appear once per page load.

Notes

This is a regression from #5080 since the postload code requires the include.preload module. We need to either combine all the content script code into one file which runs at preload, or find another way to share code between the preload and postload bundles.

Change History (4)

comment:1 Changed 20 months ago by kzar

  • Ready set
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 20 months ago by abpbot

A commit referencing this issue has landed:
Issue 5904 - Avoid include.preload.js running twice

comment:3 Changed 20 months ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 20 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. Log message only seen once.

adblockpluschrome / 1903:6b5fdb8e8e45
Chrome 62 / Windows 10
Opera 48 / Windows 10
Firefox 57 / Windows 10

Note: See TracTickets for help on using tickets.