Opened 2 years ago

Closed 3 months ago

#5918 closed defect (rejected)

ABP blocks opening of downloaded files in Edge

Reported by: Ross Assignee:
Priority: P3 Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: sebastian, oleksandr, geo Blocked By:
Blocking: Platform: Edge
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by sebastian)

Environment

ABP 0.9.11.1849 / 0.9.13.2258
Microsoft Edge 40.15063 / 41.16299 (not reproducible in 42.17134 and above)

How to reproduce

  1. Download a PDF and attempt to open it.
  2. Select to view the PDF in Edge from the dialog Windows displays.
  3. Keep selecting [Open] from the bottom dialog in Edge.
  4. Turn off ABP in [Edge Menu] > [Extensions].
  5. Select [Open] from the bottom dialog again in Edge.

Observed behaviour

ABP appears to keep blocking/closing the popup tab that opens to display the PDF.

If ABP is turned off, opening the PDF works as expected.

Expected behaviour

The PDF to open as expected with Adblock Plus enabled, on all supported versions of Microsoft Edge.

Change History (12)

comment:1 Changed 18 months ago by oleksandr

  • Resolution set to worksforme
  • Status changed from new to closed

This is an issue on older versions of Windows 10 and should be fixed in Windows 10 April Update.

comment:2 Changed 18 months ago by sebastian

Should we then advance the minimum required version accordingly?

comment:3 Changed 18 months ago by oleksandr

I would like to have a confirmation from Ross that this is indeed working now. And that it is fixed in April Update, and not Fall Creators Update, as I may be wrong which exactly update fixed the issue.

comment:4 Changed 18 months ago by oleksandr

  • Component changed from Unknown to Platform

comment:5 Changed 18 months ago by sebastian

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Sounds good, but we shouldn't close the issue yet. Either way a change is required, even if that change is just to update the minimum required version.

comment:6 Changed 12 months ago by sebastian

Ross, can you confirm?

comment:7 Changed 12 months ago by Ross

This no longer seems to be an issue. I can download and open a bunch of files types in Edge as expected.

ABP 0.9.11.2206
Edge 42.17134.1.0 / EdgeHTML 17.17134 / Windows 10 (1803)

comment:8 follow-up: Changed 12 months ago by sebastian

Thanks, but officially we are still supporting 16299 (Fall Creator's Update), 17134 is the (later) April Update. Ollie suspected above that this issue was addressed on their end with that update. Is there a way we can test this on Windows build 16299?

comment:9 in reply to: ↑ 8 Changed 9 months ago by geo

Replying to sebastian:

Thanks, but officially we are still supporting 16299 (Fall Creator's Update), 17134 is the (later) April Update. Ollie suspected above that this issue was addressed on their end with that update. Is there a way we can test this on Windows build 16299?

One of my VMs has build 16299, I can confirm that the bug was present in that version and fixed with the April Update (17134).

So, should we update the min version? (if we do, we should also check for dead code)

comment:10 Changed 9 months ago by sebastian

  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set

Thanks for confirming. Yeah, let's increase the minimum version (in metadata.edge) to 17134, and if there are any obsolete workarounds that are no longer needed then remove them while at it.

comment:11 Changed 9 months ago by sebastian

  • Cc geo added

comment:12 Changed 3 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from reopened to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.