Opened 2 years ago

Closed 2 years ago

#5957 closed defect (fixed)

adblockpluschrome unit tests are broken

Reported by: kzar Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-3.0-for-Firefox
Module: Platform Keywords:
Cc: sebastian, mjethani, trev Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29592604/

Description (last modified by kzar)

Environment

Adblock plus for Chrome devenv built from f7eff6fa3af2.

How to reproduce

  1. Open the options page.
  2. In the developer console type location.href = "qunit/index.html";

Observed behaviour

A bunch of the tests fail with Uncaught ReferenceError: browser is not defined exceptions.

Expected behaviour

The tests pass.

Notes

Hints for testers

This doesn't need testing since it won't have any effect on the build.

Change History (5)

comment:1 Changed 2 years ago by kzar

  • Owner set to kzar

comment:2 Changed 2 years ago by kzar

  • Description modified (diff)

comment:3 Changed 2 years ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 5957 - Get the unit tests passing again

comment:5 Changed 2 years ago by kzar

  • Description modified (diff)
  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.