Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5962 closed defect (rejected)

ABP plus via uBlock Origin

Reported by: kolor Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: kzar, mapx Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Hi I would like ask about specific issue.I use ABP plus but what I noticed this software don't block advert in Polish website.The same filter rules.
Now in Poland (we have first place in the World block advert) user change his blocker for uBlock Origin .Is Standing more popular.My ask about why ABP plus doesn't block advert as uBlock.
Answered was because we don't use that engine.
https://forums.lanik.us/viewtopic.php?f=62&t=38407

1.Remove ABP
2.Install uBo
3.Be sure the 2 polish lists in uBo are enabled.

ABP plus just forgot about his Polish user ???

Change History (11)

comment:1 Changed 2 years ago by kolor

Any help.

comment:3 Changed 2 years ago by mapx

  • Resolution set to rejected
  • Status changed from new to closed

comment:4 Changed 2 years ago by mapx

  • Cc kzar mapx added

comment:5 Changed 2 years ago by kzar

When filing an issue please don't simply delete the template, you need to fill it out. Things like Adblock Plus version, browser version, which filter lists are enabled, which operating system, what steps you took to reproduce the problem, what happened and what you expected to happen are all essential for us to help.

Furthermore instead of saying things like "I noticed this software don't block advert in Polish website." you need to be more specific like "Step 1. Browse to http://example.com/some-page". I'm not Polish myself, and don't have a any idea about which Polish websites you might mean otherwise.

In other words the person reading your issue has to able to reproduce the problem you're experiencing before they can understand what is happening and potentially find a solution.

Another problem with these type of issue requests is that (at least on first glance) they look more like a filter list problem than a problem with Adblock Plus. So please take the time to explain why it isn't. For example you might say "The advert in question is blocked in uBlock, using the following filter: ...".

We do want to help you of course, we haven't forgotten about our Polish users and we do appreciate the time taken to file issue reports.

comment:6 Changed 2 years ago by mapx

@Dave, the problem here is those sites (fakt, wp) are using a lot of inline scripts to push out the ads. The most active polish list is using uBo specific filters to block such crap. The "traditional" polish list (ABP alike) is not very active to find ABP specific solutions (if ever possible - given that ABP does not want to implement uBo-injecting filters).
The user (kolor) wants to use ABP (he refuses uBo :D )...but nobody can support him. A real dilemma !

comment:7 Changed 2 years ago by kzar

Fair enough but it would be useful if he could file a proper issue which lists the websites and adverts in question, and which uBo specific filters worked to block them. Then at least we'd have a chance to help. For example perhaps the $csp filter option #5241 would help him? (Unfortunately not much progress adding that at the moment, the mess with Firefox 57 is taking up all of my time.)

comment:8 Changed 2 years ago by kzar

  • Component changed from Unknown to Platform

comment:9 Changed 2 years ago by mapx

the big difference (blocks a lot of ads) is due to this uBo specific filter

wp.pl##script:inject(abort-on-property-read.js, WP.inline)

from https://github.com/MajkiIT/polish-ads-filter/blob/master/polish-adblock-filters/adblock_ublock.txt

comment:10 Changed 2 years ago by kolor

"The user (kolor) wants to use ABP (he refuses uBo :D )...but nobody can support him"
Yes it is truth.I'm not familiar how it all works .I only can complain.

Polish list do not support as who use ABP plus .

mapx said me to tell Wladimir to add support for "inline javascript" to fight better the ads on polish sites.

Polish website sleep deep dreams.
https://easylist-downloads.adblockplus.org/easylistpolish.txt

What I can do more my buddys

Last edited 2 years ago by mapx (previous) (diff)

comment:11 Changed 2 years ago by mapx

However, I don't know how much time ABP will continue to ignore the new generations of ads - all using inline scripts.

There are old (2-3 years !) tickets where was requested such approach:
https://issues.adblockplus.org/ticket/756
https://issues.adblockplus.org/ticket/3207

Last edited 2 years ago by mapx (previous) (diff)
Note: See TracTickets for help on using tickets.