Opened 12 months ago

Closed 11 months ago

Last modified 11 months ago

#5965 closed defect (fixed)

ABP subscribe links do not function in Firefox

Reported by: Ross Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-3.0.2-for-Firefox
Module: Platform Keywords:
Cc: trev, sebastian, mjethani, mapx Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29604555/

Description

Environment

ABP 2.99.0.1902beta
Firefox 57 / Windows 10

How to reproduce

  1. Select a subcribe link from https://adblockplus.org/subscriptions

Observed behaviour

The ABP options page is opened, but no confirmation dialog is displayed and no list is added.

Expected behaviour

The options page to open, a confirmation dialog to appear and the list to be subscribed to on confirmation.

Attachments (1)

5965-screenshot.png (206.6 KB) - added by kzar 11 months ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 12 months ago by Ross

This worked in a previous build (1889 IIRC)

comment:2 Changed 12 months ago by sebastian

  • Cc manish added
  • Component changed from Unknown to Platform
  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 12 months ago by mjethani

  • Cc mjethani added; manish removed

comment:4 Changed 12 months ago by mjethani

I tried to reproduce this issue with Firefox 57.0b12 on macOS with 2.99.0.1902beta, 2.99.0.1907beta, and master, and in all three cases it worked fine.

Ross, could you try again with the latest build and, if possible, on both macOS and Windows?

comment:5 Changed 12 months ago by trev

Ross mentioned already that this doesn't seem to be reproducible reliably. Also, I have a strong suspicion that this is a Windows-only issue like #5817. At least I wasn't able to reproduce on Linux.

comment:6 Changed 12 months ago by mapx

windows tests FF 57, ABP 3.0.0.1911beta:

  1. click subscribe a list (on this page) https://adblockplus.org/subscriptions
  2. options page is opened, no confirmation dialogue
  3. stay on options page and click again the subscribing link ==> now the confirmation dialogue is opened.
  4. if I click again subscribing for the same list => the addon does not warning the list is already subscribed.

However, I get no error in console.

Last edited 12 months ago by mapx (previous) (diff)

comment:7 Changed 12 months ago by mapx

  • Cc mapx added

comment:8 Changed 12 months ago by Ross

Reproduced steps mapx has added. If the options page is not already open, the dialog does not appear. If the options page is already open it does. There is also no warning about adding a duplicate subscriptions.

I've also noticed that the subscription is added before the confirmation dialog is answered, and if the user chooses "no" (via the top right X) the subscription is still present.

ABP 3.0.1
Firefox 57 / Windows 10

comment:9 Changed 12 months ago by mapx

  • Cc greiner added

comment:10 Changed 12 months ago by trev

  • Cc greiner removed

While I am still unable to reproduce this issue using these steps, I'm fairly certain that it is the same issue as in #5817 - the message sent to the options page arrives before the page is ready. So it's not a UI issue but rather still Platform.

comment:11 Changed 12 months ago by trev

Actually - no, the code seems to wait for the page to be ready already.

comment:12 Changed 11 months ago by kzar

I've not been able to reproduce this on Debian Buster with Firefox 57.0b9, I'll have a try with Windows 10 when I get a chance.

comment:13 Changed 11 months ago by kzar

I can reproduce this with Alockplus 3.0.1 on Firefox 57.0 and Windows 10.

comment:14 Changed 11 months ago by kzar

  • Owner set to kzar

Going to stop soon but I'll investigate further next week.

comment:15 Changed 11 months ago by kzar

The message responder for "subscriptions.add" calls showOptions, but the callback for showOptions is not being made. It seems that's because findOptionsTab in lib/options.js is returning undefined, despite searching for the correct URL for the options page.

It seems this is because the tab Object that browser.tabs.query is returning for the options page has a url of "about:blank" (but a title containing the URL we were expecting). I'll attached a screenshot to show what I mean.

Changed 11 months ago by kzar

comment:16 Changed 11 months ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:17 Changed 11 months ago by abpbot

A commit referencing this issue has landed:
Issue 5965 - Handle edge case when searching for options page tab

comment:18 Changed 11 months ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:19 Changed 11 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed in Firefox 51-57. I've added a note to #5971 for Firefox 50.
Still works as expected in Chrome/Opera.

ABP 3.0.1.1939
Firefox 51 / 57 / Windows 7
Firefox 57 / Galaxy J5 / Android 6.0.1
Chrome 49 / 62 / Windows 7
Opera 36 / 48 / Windows 7

Last edited 11 months ago by Ross (previous) (diff)
Note: See TracTickets for help on using tickets.