Opened 12 months ago

Closed 11 months ago

Last modified 11 months ago

#5972 closed defect (fixed)

[webextension] ABP Options page is titled "Settings"

Reported by: Ross Assignee: saroyanm
Priority: P3 Milestone:
Module: User-Interface Keywords: options-page, goodfirstbug
Cc: trev, sebastian, greiner, Shikitita, saroyanm, lisabielik, jeen, wspee Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29616602/
https://codereview.adblockplus.org/29616607/

Description

Environment

ABP 2.99.0.1903beta
Firefox 57 / Windows 10

How to reproduce

  1. Select [ABP Icon] > [Options].

Observed behaviour

The ABP Options page is titled just "Settings. This is a disconnect from the UI the user just opened it with ("Options") making it slightly confusing. In Chrome the page is titled "Adblock Plus Options".

The page is displays no favicon.

Expected behaviour

The title of the options page should probably be "Adblock Plus Options" and also display a favicon (if supported).

Change History (12)

comment:1 Changed 12 months ago by saroyanm

  • Priority changed from Unknown to P4
  • Ready set

comment:2 Changed 12 months ago by saroyanm

  • Keywords options-page added

comment:3 Changed 11 months ago by kzar

  • Cc greiner Shikitita saroyanm added

This appears to be caused by a problem in adblockplusui/locale/en_US/desktop-options.json, the string "options_page_title" is listed twice:

  "options_page_title": {
    "description": "Options page title",
    "message": "Adblock Plus Options"
  },
  "options_page_title": {
    "description": "Page title in navigation sidebar",
    "message": "Settings"
  },

comment:4 Changed 11 months ago by Shikitita

  • Cc lisabielik jeen wspee added

comment:5 Changed 11 months ago by greiner

  • Keywords goodfirstbug added
  • Priority changed from P4 to P3

comment:6 Changed 11 months ago by saroyanm

  • Owner set to saroyanm

comment:7 Changed 11 months ago by saroyanm

  • Review URL(s) modified (diff)

comment:8 Changed 11 months ago by saroyanm

  • Status changed from new to reviewing

comment:9 Changed 11 months ago by abpbot

A commit referencing this issue has landed:
Issue 5972 - Fixed wrong options page title

comment:10 Changed 11 months ago by abpbot

A commit referencing this issue has landed:
Issue 5972 - Added favicon to the options page wrapper

comment:11 Changed 11 months ago by saroyanm

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:12 Changed 11 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Done.

ABP 3.0.1.1939
Firefox 51 / 57 / Windows 10

Note: See TracTickets for help on using tickets.