Opened 2 years ago

Closed 2 years ago

#5975 closed defect (fixed)

[webextension] Report link does nothing in Firefox issue reporter

Reported by: Ross Assignee: trev
Priority: P1 Milestone:
Module: User-Interface Keywords:
Cc: trev, sebastian Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29595595/

Description (last modified by trev)

Environment

ABP 2.99.0.1903beta
Firefox 57 / Windows 10

Works in Chrome.

How to reproduce

  1. Navigate to a website (any).
  2. Select [ABP Icon] > [Report issue on this page].
  3. Complete the issue submit process.
  4. Attempt to select the report link.

Observed behaviour

Selecting the report link appears to do nothing. In Chrome it appears to work as described below.

Expected behaviour

The report link to open the report page.

Change History (6)

comment:1 Changed 2 years ago by trev

"Done" button is a duplicate of #5952. Report link is new.

comment:2 Changed 2 years ago by trev

  • Owner set to trev

comment:3 Changed 2 years ago by trev

  • Description modified (diff)
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

I changed the description to remove the Done button issue which is unrelated. My review only addresses the broken report link.

comment:4 Changed 2 years ago by greiner

  • Priority changed from Unknown to P1
  • Ready set

comment:5 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 5975 - Allow report link to work in Firefox

comment:6 Changed 2 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed
  • Summary changed from [webextension] Report link and button do nothing in Firefox issue reporter to [webextension] Report link does nothing in Firefox issue reporter
Note: See TracTickets for help on using tickets.