Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5997 closed defect (fixed)

Unit test files are included in the release build

Reported by: kzar Assignee: kzar
Priority: P2 Milestone:
Module: Automation Keywords:
Cc: tlucas, trev, sebastian Blocked By:
Blocking: #6022 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29600577/

Description (last modified by kzar)

Environment

adblockpluschrome b9be53e411d7

How to reproduce

  1. ./build.py -t chrome build
  2. unzip adblockpluschrome-3.0.0.1851.zip -d /tmp/adblockpluschrome
  3. ls /tmp/adblockpluschrome/qunit/

Observed behaviour

The qunit directory exists and it contains two files tests.js and tests.js.map.

Expected behaviour

Neither the directory nor those files should exist.

Notes

This is a regression caused by the webpack related changes.

Integration notes

Some metadata changes will be required:

  • Remove tests.js from [general] testScripts.
  • Remove qunit/tests.js from [bundles].

Change History (6)

comment:1 Changed 2 years ago by tlucas

  • Priority changed from Unknown to P2
  • Ready set

comment:2 Changed 2 years ago by kzar

  • Description modified (diff)
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 5997 - Avoid including qunit files in release builds

comment:4 Changed 2 years ago by kzar

  • Blocking 6022 added

comment:5 Changed 2 years ago by kzar

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 2 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Done. Files no longer present in builds.

adblockpluschrome / 1939:43e804dddf0e

Note: See TracTickets for help on using tickets.