Opened 20 months ago

#5999 new defect

ABB Settings slow to load

Reported by: traynard Assignee:
Priority: Unknown Milestone:
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Android (verified on 5.0.1 and 7.0)
Adblock Browser 1.2 and 1.3

How to reproduce

  1. Open ABB (issue is more prominent after restarting device)
  2. Open Menu > Settings
  3. Tap on "Ad Blocking"

Observed behaviour

Settings can be slow to load. It causes settings to show greyed out and cannot be interacted with. At times, this behavior remains until the page is somehow interacted with (either a setting is tapped, app is existed, back button tapped etc). Other times, settings will re-enable by themselves after a few seconds. Similar issue has also been reported by a user on ABB 1.2

NOTE: User's report was regarding settings in the menu (such as "Block ads on this page" checkbox. Although I could not personally reproduce this, it seems to be related. Screenshot attached.

Expected behaviour

Settings should always load quickly without required action from user.

Attachments (2)

abbad.png (524.0 KB) - added by traynard 20 months ago.
User's report
SettingsGrey.png (85.6 KB) - added by traynard 20 months ago.

Download all attachments as: .zip

Change History (2)

Changed 20 months ago by traynard

User's report

Changed 20 months ago by traynard

Note: See TracTickets for help on using tickets.