Opened 2 years ago

Closed 19 months ago

#6000 closed change (fixed)

Rename "libadblockplus-android"

Reported by: asmirnov Assignee:
Priority: P4 Milestone:
Module: Libadblockplus-Android Keywords:
Cc: fhd, sergz, diegocarloslima, jwangenheim, rjeschke Blocked By: #6300
Blocking: #6205 Platform: Android
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29678581/
https://codereview.adblockplus.org/29782630/

Description

Background

For historical reason and to be consistent with other eyeo products libadblockplus-android is named the way it is at the moment. However this seems to be confusing for Android developers (according to Felix at android dev meeting) and should be improved.

What to change

Rename libadblockplus-android to something more common to Android developers.

Change History (17)

comment:1 Changed 2 years ago by asmirnov

comment:2 Changed 2 years ago by asmirnov

Android guys, what's your suggestion? I's name it "Adblock Plus Android SDK"

Last edited 2 years ago by asmirnov (previous) (diff)

comment:3 Changed 2 years ago by asmirnov

  • Cc rjeschke added

comment:4 follow-up: Changed 2 years ago by jwangenheim

I think 'Adblock Plus Android SDK' would be a good choice . The only alternative I could imagine would be something like "Adblock WebView" but

  1. We offer more than only a WebView that blocks ads and probably we want to extend the functionality in the future
  2. It makes more sense to have the product name reflected in the name of the lib.

comment:5 in reply to: ↑ 4 Changed 2 years ago by asmirnov

Replying to jwangenheim:

I think 'Adblock Plus Android SDK' would be a good choice . The only alternative I could imagine would be something like "Adblock WebView" but

  1. We offer more than only a WebView that blocks ads and probably we want to extend the functionality in the future

BTW AdblockWebView is not the only module provided and the users can use 'libadblockplus-android' submodule without 'libadblockplus-android-webview' used.

  1. It makes more sense to have the product name reflected in the name of the lib.

comment:6 Changed 2 years ago by jwangenheim

Yeah, that's exactly what I meant by 1. :) I just could image Adblock-Webview as a name for the lib, becuse it's probably the most striking and easy to implement feature.

Last edited 2 years ago by jwangenheim (previous) (diff)

comment:7 Changed 2 years ago by sergz

I like Adblock Plus Android SDK.

In order to handle WebView I would like to firstly know what will be changed when the product is renamed. In particular if the everything continues to live in the same repo libadblockplus-android then we can have proper names for each component, one has to just figure out how to properly work with them, namely, build, distribute and convey, etc. E.g. take a look at spotify, they have SDK consisting from several libraries and it's shortly explain in The SDK's structure section.

comment:8 Changed 2 years ago by fhd

I think we can leave out the _Plus_, we did the same for Adblock Browser and AdblockWebView. As in Adblock Android SDK.

comment:9 Changed 2 years ago by diegocarloslima

I would suggest the full name for README /docs to be Adblock SDK for Android and the contracted version for ids / repo name to be Adblock-SDK-Android

Last edited 2 years ago by diegocarloslima (previous) (diff)

comment:10 Changed 2 years ago by jwangenheim

Hey guys,

should we make a final decision here? I like 'Adblock Android SDK' as a name for the whole repository. But I think it would also make sense to distribute libadblockplus-android, libadblockplus-android-settings and libadblockplus-android-webview as single maven dependencies, to make adblocking in Android apps available as fast and easy as possible.

comment:11 Changed 2 years ago by asmirnov

it would also make sense to distribute libadblockplus-android, libadblockplus-android-settings and libadblockplus-android-webview as single maven dependencies

I don't think it's good idea, i see no point in making it single module at all. Using of 'libadblockplus-android' does not mean using 'libadblockplus-android-webview', similar to settings - they are independent of WebView (see https://github.com/adblockplus/libadblockplus-android/blob/master/libadblockplus-android-settings/pom.xml).

What about module dependencies i prefer leave everything as-is, but just rename the modules.

comment:12 Changed 2 years ago by diegocarloslima

  • Blocking 6205 added

comment:13 Changed 23 months ago by asmirnov

  • Blocked By 6300 added

comment:14 Changed 23 months ago by asmirnov

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:15 Changed 19 months ago by diegocarloslima

  • Review URL(s) modified (diff)

comment:16 Changed 19 months ago by abpbot

A commit referencing this issue has landed:
Issue 6000 - Rename "libadblockplus-android"

comment:17 Changed 19 months ago by diegocarloslima

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.