#6002 closed defect (invalid)

About:Blank does not clear page

Reported by: traynard Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: mapx, trev, sebastian, manish Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Firefox with ABP 3.0

How to reproduce

Ensure ABP is enabled

  1. Navigate to any website
  2. In address bar, remove current URL and enter "About:blank" and submit

Observed behaviour

The address bar is cleared and user can no longer interact with webpage (other than scrolling) but the page is not cleared or "blank" as expected until tabs are switched.

Expected behaviour

after navigating to about:blank, page should be fully cleared.

NOTE: This works fine when ABP is not installed.

Change History (8)

comment:2 Changed 20 months ago by mapx

  • Cc mapx trev added

comment:3 Changed 20 months ago by mapx

error in browser console:

Failed to execute ‘postMessage’ on ‘DOMWindow’: The target origin provided 
(‘https://www.google.it’) does not match the recipient window’s origin (‘null’).

I can reproduce the issue in FF 56 but not in FF 57

Last edited 20 months ago by mapx (previous) (diff)

comment:4 Changed 19 months ago by trev

  • Cc sebastian manish added
  • Component changed from Adblock-Plus-for-Firefox to Platform

I can also reproduce in Firefox 56. No error message in my case - this error seems to be caused by the particular website and unrelated. This is some kind of Firefox bug, need to be narrowed down.

comment:6 Changed 19 months ago by trev

The only strange thing: gorhill filed that bug for Firefox 58, yet I cannot reproduce it with this Firefox version. But if his analysis is correct, we cannot really avoid hitting this bug.

comment:7 Changed 19 months ago by mapx

Yeah, he corrected himself, it's about the same buggy FF 56.

comment:8 Changed 19 months ago by trev

  • Resolution set to invalid
  • Status changed from new to closed

Then I wonder why he even bothered reporting the bug. It's not like anybody will bother backporting the fix to Firefox 56. If it's fixed in Firefox 57 then all we need to do is wait a week for Firefox 57 to become the current stable release.

Resolving as "invalid" meaning: not our bug and no way of fixing this on our end.

Note: See TracTickets for help on using tickets.