Opened 2 months ago

Closed 2 months ago

Last modified 7 weeks ago

#6010 closed defect (fixed)

Filter list blocked by ABP 3

Reported by: mapx Assignee: trev
Priority: P2 Milestone: Adblock-Plus-3.0.2-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: trev, sebastian, mjethani, kzar Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29602570/

Description (last modified by trev)

Environment

w10
FF 57
ABP 3

How to reproduce

  • add this filter _bg
  • go to https://adblockplus.org/en/subscriptions
  • click subscribe bulgarian list (having this address http://stanev.org/abp/adblock_bg.txt )

Observed behaviour

  • in the filter lists section I get Failed, download failure

Expected behaviour

The list should be correctly downloaded / added to ABP (as in ABP legacy)

Reported here: https://adblockplus.org/forum/viewtopic.php?f=1&t=54425

What to change

webRequest in Firefox will give us an originUrl property that allows recognizing internal requests. We should ignore anything where originUrl starts with chrome:// or moz-extension://. No such property on Chrome, recognizing internal requests doesn't seem possible there.

Change History (11)

comment:1 Changed 2 months ago by mapx

  • Description modified (diff)

comment:2 Changed 2 months ago by trev

  • Cc greiner removed
  • Component changed from Adblock-Plus-for-Firefox to Platform

I can confirm that filter list downloads are subject to our filter rules both in Firefox and Chrome. I guess that this is a side-effect of #5042.

comment:3 Changed 2 months ago by kzar

  • Priority changed from Unknown to P2
  • Ready set

comment:4 Changed 2 months ago by trev

  • Description modified (diff)
  • Owner set to trev

comment:5 Changed 2 months ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 2 months ago by abpbot

comment:7 Changed 2 months ago by trev

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Platform changed from Unknown / Cross platform to Firefox
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 2 months ago by mapx

The webRequest API only exposes requests that the extension has permission to see,
given its host permissions. Moreover, only the following schemes are accessible: 
http://, https://, ftp://, file://, ws:// (since Chrome 58), wss:// (since Chrome 58),
or chrome-extension://

from https://developer.chrome.com/extensions/webRequest

Is it possible (for chrome) to use chrome-extension:// to identify the origin of the request ?

comment:9 Changed 2 months ago by trev

Chrome doesn't expose the origin of the request. In other words: no, not possible.

comment:10 Changed 2 months ago by Ross

Fixed. Haven't checked fix in Firefox 50 due to #5971.

ABP 3.0.1.1934beta
Firefox 57 / Windows 10

comment:11 Changed 7 weeks ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed in Firefox. Re-tested with _ar list as several of the easylist files seem to have been renamed (ex: "bulgarian_list").

Still blocks request in Chrome/Opera, but as I understand from the above that is currently expected behaviour.

ABP 3.0.1.1939
Firefox 51 / 57 / Windows 7
Chrome 49 / 62 / Windows 7
Opera 36 / 48 / Windows 7

Note: See TracTickets for help on using tickets.