Opened 23 months ago

Closed 23 months ago

Last modified 6 months ago

#6011 closed defect (worksforme)

Adblock Plus messes up "Inbox by Gmail" reply functions

Reported by: smrtsmart Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: mapx, trev, sebastian Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):



Fedora 25
Firefox 56.0
Adblock Plus 3.0.1
EasyList China+EasyList

How to reproduce

  1. Go to and login to a gmail account
  2. Click on any email and click "Reply"
  3. Type something.

Observed behaviour

The "Send" button is permanently disabled and I can't send. Other buttons, such as "Discard Draft," become dysfunctional. This happens even if is whitelisted in Adblock Plus. I can click "Pop out reply" and the buttons on that popped-out window become functional again. This bug was not present in ABP 2.9.1.

Expected behaviour

Adblock Plus should not mess up the "Reply" function on, especially if the website is whitelisted.

Change History (10)

comment:1 Changed 23 months ago by mapx

Could you test in FF 57 ? (use eventually firefox portable from

comment:2 Changed 23 months ago by mapx

  • Cc mapx trev sebastian added

comment:3 Changed 23 months ago by trev

I doubt that Firefox version matters. It's more likely a false positive caused by a filter that used to be processed in a slightly different way in the previous version.

comment:4 Changed 23 months ago by mapx

I tested myself: no issue in FF 57 using easylist + easyprivacy + easy china.

@smrtsmart be sure you are not using in FF 56 other old (legacy) addons

Last edited 23 months ago by mapx (previous) (diff)

comment:5 follow-up: Changed 23 months ago by trev

That's not surprising, there is no issue in Firefox 56 either. As I said, this should be an issue with the filters.

@smrtsmart: Maybe you could go into Adblock Plus options, switch to Advanced and tell us what you have there. Meaning: what filter lists are active and what filters you have in your own filter list.

comment:6 in reply to: ↑ 5 Changed 23 months ago by mapx

Replying to trev:

That's not surprising, there is no issue in Firefox 56 either.

If the user has other old legacy addons it could break the visited pages (known issue in FF 56 + new framework system)

comment:7 Changed 23 months ago by smrtsmart

Well I tried disabling all addons except ABP in Firefox 56, changed the filter to EasyList only and updated it to the latest version, but still it breaks in the same way no matter what option I tried. I can get Inbox to work only if I disable the ABP addon.

The problem seems to disappear however after I have upgraded to Firefox 57 via So maybe it's a bug specific to FF 56 on Linux. Thanks all for your help and I suppose you can close this ticket now.

comment:8 Changed 23 months ago by mapx

  • Resolution set to worksforme
  • Status changed from new to closed

comment:9 Changed 23 months ago by trev

That's too bad, I still cannot reproduce this issue in Firefox 56 on Ubuntu. If it is some browser bug we better figure it out :-/

comment:10 Changed 6 months ago by Thanos

Last edited 6 months ago by mapx (previous) (diff)
Note: See TracTickets for help on using tickets.