Opened 7 months ago

Last modified 5 months ago

#6028 reopened defect

thunderbird addon listing gone

Reported by: stuotrik Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: mapx Blocked By:
Blocking: Platform: Thunderbird
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Adblock Plus no longer shows up in a search for Thunderbird addons on AMO:
https://addons.mozilla.org/en-US/thunderbird/search/?q=adblock+plus&appver=&
platform=

I presume this is because the main listing has been converted to webextension which is currently not supported by thunderbird.

Will the "legacy" version of the addon going to be maintained for thunderbird? Even if no, could the last version be re-listed on AMO?

Change History (8)

comment:2 Changed 6 months ago by mapx

  • Cc trev mapx added

comment:3 follow-up: Changed 6 months ago by trev

  • Resolution set to invalid
  • Status changed from new to closed

Sorry, there is nothing we can do about that. The last Adblock Plus version to support Thunderbird is Adblock Plus 2.9.1. You can find it in the version history (link by mapx above) but AMO supports only one "current" version - that's 3.0.1 right now. So finding Adblock Plus for Thunderbird is going to be complicated and we cannot publish updates.

comment:4 Changed 6 months ago by stuotrik

  • Resolution invalid deleted
  • Status changed from closed to reopened

thanks for pointing to where it can be downloaded (although that will be harder and harder to find as more releases come out) ...

trev, i believe it's possible to create a separate listing -- it could be called e.g. "Adblock Plus for Thunderbird" ... I'm sure there are many who would appreciate that small step. It would be even better if the extension continued to be maintained, but at least making the current (still working) version discoverable would be helpful.

comment:5 follow-up: Changed 6 months ago by trev

  • Resolution set to invalid
  • Status changed from reopened to closed

A separate listing would require a new extension ID. This means that it wouldn't be served as an update for the existing extension and it wouldn't replace it if installed manually. We also simply don't have the resources to maintain it (doesn't help that I am the only developer with in-depth Gecko knowledge), nor is it clear at this point how long Thunderbird in its current form is going to exist.

comment:6 in reply to: ↑ 3 Changed 6 months ago by tibitts

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to trev:

Sorry, there is nothing we can do about that. The last Adblock Plus version to support Thunderbird > is Adblock Plus 2.9.1.

There's also version 2.9.1.4260-beta, which works with Thunderbird 56. It's accessible via the 'Development Channel' section on AMO.
The problem is, neither v2.9.1 nor v2.9.1.4260-beta work with TB57.

You can find it in the version history (link by mapx above) but AMO supports only one "current"
version - that's 3.0.1 right now. So finding Adblock Plus for Thunderbird is going to be
complicated and we cannot publish updates.

While this is true, publishing a fixed version for TB57 in the Development Channel should be possible, and not interfere with the "current" version 3.0.1.
A working version in the Development Channel would still be way better than no working version for Thunderbird at all. Please consider this option.

comment:7 in reply to: ↑ 5 Changed 6 months ago by tibitts

Replying to trev:

We also simply don't have the resources to maintain it (doesn't help that I am the only developer
with in-depth Gecko knowledge), nor is it clear at this point how long Thunderbird in its current
form is going to exist.

Fixing Adblock Plus for TB57 wouldn't require ground breaking changes. All the "breakage" of add-ons in TB57 is due to changed/removed interfaces, but add-on authors can adapt/workaround those.

Please also take a look at this 'Add-ons Guide for Thunderbird 57 and beyond' detailing the changes needed, and what to expect for future Thunderbird versions.
https://wiki.mozilla.org/Thunderbird/Add-ons_Guide_57

This is another statement from a Thunderbird developer (jorgk):
"Add-ons like "Adblock Plus" or "uBlock Origin" have moved to WebExtensions and
users may want to use them in TB for feeds. Some WebExtension support in TB is
needed (ironically) to keep legacy add-ons working, for example allowing those
which need inline options to become "hybrid" add-ons."

Please consider updating ABP for TB57.

comment:8 Changed 5 months ago by fhd

  • Cc trev removed
Note: See TracTickets for help on using tickets.