Opened 22 months ago

Closed 21 months ago

Last modified 21 months ago

#6039 closed defect (worksforme)

[webextension] Pinterest feed opens blank pages

Reported by: traynard Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: mapx, trev, kzar, sebastian, mjethani Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by kzar)

Environment

Firefox (56 - 57), ABP 3.0.1, Windows 10
Enabled subscriptions: EasyList and AA

How to reproduce

  1. Login to Pinterest account (existing account with non-default feed)
  2. Click on a pin in the feed. Must be one which was saved by other users and has a description (bold text below the pin on the feed).
  3. Click on opened pin to visit page

Observed behaviour

Page opens in new tab and is blank. Site is not rendered unless browser is resized.

If Adblock Plus is disabled, this works as expected.

Expected behaviour

Pages should open as expected and display linked content.

Reported by multiple users. Here's a video example.

Change History (15)

comment:1 Changed 22 months ago by traynard

Note: "Disabled on this site" option in ABP does not resolve the issue. In order to bypass the issue, the whole addon must be disabled or removed.

comment:3 Changed 22 months ago by traynard

I've verified that the issue still exists on FF 57

comment:4 Changed 22 months ago by mapx

  • Cc mapx trev kzar added

comment:5 Changed 22 months ago by kzar

I can't reproduce this with Firefox 57 on Linux (Debian Buster), nor on Windows 10.

comment:6 Changed 22 months ago by kzar

  • Cc sebastian mjethani added
  • Component changed from Unknown to Platform
  • Summary changed from Pinterest feed opens blank pages to [webextensions] Pinterest feed opens blank pages

comment:7 follow-up: Changed 22 months ago by kzar

Can anyone who can reproduce this issue confirm which filter subscriptions (including AA) and custom filters they have enabled?

comment:8 Changed 22 months ago by mapx

I cannot reproduce too (FF 57).
Perhaps it's some pinterest edge case ? (existing account with non-default feed) => I tested with exactly the same page Tasha reported in the video.

Last edited 22 months ago by mapx (previous) (diff)

comment:9 follow-up: Changed 22 months ago by traynard

Are you guys testing with existing pinterest accounts? It seems the issue only exists if you open pins which have been saved by other users and have a description added to the pin (bold text below the pin on the feed). I created a brand new account and could not replicate that way, but tried 2 different existing pinterest accounts on mac and windows 10 and could reproduce each time on FF 57.

Last edited 22 months ago by traynard (previous) (diff)

comment:10 in reply to: ↑ 9 Changed 22 months ago by kzar

Replying to traynard:

Are you guys testing with existing pinterest accounts?

Yup, I borrowed my girlfriend's account but no joy.

comment:11 in reply to: ↑ 7 Changed 22 months ago by traynard

Replying to kzar:

Can anyone who can reproduce this issue confirm which filter subscriptions (including AA) and custom filters they have enabled?

AA Enabled (only allow ads without third-party tracking disabled)
EasyList
Adblock Warning Removal is disabled

comment:12 Changed 22 months ago by kzar

  • Description modified (diff)

comment:13 Changed 22 months ago by kzar

  • Summary changed from [webextensions] Pinterest feed opens blank pages to [webextension] Pinterest feed opens blank pages

comment:14 Changed 21 months ago by kzar

  • Resolution set to worksforme
  • Status changed from new to closed

Closing this one for now since neither mapx nor I can reproduce. Let me know if this is still happening for our users and I can reopen.

comment:15 Changed 21 months ago by traynard

Got another report on this issue from a user 7 days ago

Note: See TracTickets for help on using tickets.