Opened 5 weeks ago

Closed 5 weeks ago

Last modified 3 weeks ago

#6046 closed defect (fixed)

[webextension] Mobile options page is zoomed out

Reported by: greiner Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-3.0.2-for-Chrome-Opera-Firefox
Module: Platform Keywords:
Cc: kzar, Ross, sebastian, trev Blocked By:
Blocking: Platform: Firefox Mobile
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29610555/

Description (last modified by kzar)

Environment

Nexus 5X
Android 8
Firefox 57
Adblock Plus 3.0.1

ALSO

Moto G4 Plus, Firefox 57b12, Adblock Plus 3.0.1, Android 7.0

How to reproduce

Open the Adblock Plus options page

Observed behaviour

The entire UI looks small and zoomed out. Zooming in manually changes the UI to look normal. (See attached screenshot.)

Expected behaviour

Text is legible and other parts of the UI also look normally sized.

Attachments (2)

Screenshot_20171116-135234.png (114.8 KB) - added by kzar 5 weeks ago.
Screenshot_20171116-135950.png (56.9 KB) - added by kzar 5 weeks ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 5 weeks ago by greiner

@Ross @kzar Can you reproduce this issue?

This used to work when we implemented it and AFAIK nothing has changed since then. Therefore I don't know yet whether this is an issue with the UI, the extension or the platform.

comment:2 Changed 5 weeks ago by kzar

  • Cc sebastian trev added
  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Platform changed from Unknown / Cross platform to Firefox Mobile
  • Priority changed from Unknown to P2
  • Ready set
  • Summary changed from Mobile options page is zoomed out to [webextensions] Mobile options page is zoomed out

I can reproduce this.

Changed 5 weeks ago by kzar

comment:3 Changed 5 weeks ago by kzar

Oh, I was observing #5977 since that screenshot is of the popup UI. But when I click "Options" from the popup UI the options page is also zoomed out. I'll attach another screenshot.

Changed 5 weeks ago by kzar

comment:4 Changed 5 weeks ago by kzar

  • Owner set to kzar

I think we just need to add the viewport meta tag to adblockpluschrome/options.html. I've just tried adding that in using USB debugging and it seemed to work OK.

comment:5 Changed 5 weeks ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 5 weeks ago by abpbot

A commit referencing this issue has landed:
Issue 6046 - Ensure mobile options page is zoomed correctly

comment:7 Changed 5 weeks ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 3 weeks ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed.

ABP 3.0.1.1939
Firefox 57 / Galaxy J5 / Android 6.0.1
Firefox 57 / Iconia Tab 8 / Android 4.4.4

comment:9 Changed 3 weeks ago by kzar

  • Summary changed from [webextensions] Mobile options page is zoomed out to [webextension] Mobile options page is zoomed out
Note: See TracTickets for help on using tickets.