Opened 13 months ago

Closed 13 months ago

Last modified 12 months ago

#6053 closed defect (fixed)

[webextension] Buttons in "block element" dialog do not work in Windows

Reported by: kzar Assignee: kzar
Priority: P1 Milestone: Adblock-Plus-3.0.2-for-Firefox
Module: Platform Keywords: externaldependencies
Cc: mapx, trev, sebastian Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29612656/

Description (last modified by kzar)

Environment

Windows 10, Firefox 57, adblockpluschrome 35cfeacaa3f8

How to reproduce

  1. Browse to https://google.co.uk
  2. Click the ABP icon
  3. Select "Block element"
  4. Click on the Google logo image
  5. Click on the the "Add" or "Cancel" buttons

Observed behaviour

Nothing appears to happen when either button is clicked, but the following exception appears in the console:

Scripts may not close windows that were not opened by script.
composer.js:64:2

Note: When the "Add" button is clicked the filter actually _is_ added, but since the window doesn't close that is not obvious to the user!

Expected behaviour

Both buttons should close the window when clicked.

Notes

  • See related discussion in #5817.
  • I can not reproduce this on Linux, only Windows.

Change History (8)

comment:1 Changed 13 months ago by kzar

  • Description modified (diff)

comment:2 Changed 13 months ago by kzar

  • Keywords externaldependencies added

I've opened a Firefox bug for this https://bugzilla.mozilla.org/show_bug.cgi?id=1418394

comment:3 Changed 13 months ago by trev

There is an extra allowScriptsToClose flag that can be passed to windows.create() in Firefox, added in https://bugzilla.mozilla.org/show_bug.cgi?id=1301227.

comment:4 Changed 13 months ago by kzar

  • Owner set to kzar

comment:5 Changed 13 months ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 13 months ago by abpbot

A commit referencing this issue has landed:
Issue 6053 - Workaround window.close problem on Firefox

comment:7 Changed 13 months ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 12 months ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. Buttons on block element dialog work as expected.

(In Firefox 50/51, cancelling the dialog can leave the highlight on the page, but is probably related to #6113).

ABP 3.0.1.1939
Firefox 52 / 59 / Windows 10
Chrome 52 / 62 / Windows 7
Opera 39 / 49 / Windows 7

Last edited 12 months ago by Ross (previous) (diff)
Note: See TracTickets for help on using tickets.