Opened 2 years ago

Closed 2 years ago

#6068 closed defect (rejected)

Disabling extensions.adblockplus.subscriptions_autoupdate does not work anymore

Reported by: Sworddragon Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: trev, mapx, jeen, kzar Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Operating system: Ubuntu 18.04 dev
Browser: Firefox 56
Adblock Plus: 3.0.1

How to reproduce

Go to about:config and set extensions.adblockplus.subscriptions_autoupdate to false.

Observed behaviour

Filter lists still get updated automatically.

Expected behaviour

Filter lists shouldn't get updated automatically.

Change History (8)

comment:1 Changed 2 years ago by mapx

ABP 3 does not use anymore those prefs

comment:2 Changed 2 years ago by mapx

  • Cc trev mapx added

comment:3 Changed 2 years ago by Sworddragon

Is this a limitation from the new web extensions API? Or is there another specific reason to not use this setting anymore?

comment:5 Changed 2 years ago by Sworddragon

So it seems the storage format has changed to not use about:config anymore possibly due to a web extensions limitation. At least the settings are still available and can be changed but this way is a bit more tricky than the old way over about:config. Maybe the settings page can have something like its own about:config emulation for all those settings. Also, are these settings and the way to get/set them officially documented somewhere?

comment:6 Changed 2 years ago by trev

  • Cc jeen added

Yes, Web Extensions APIs don't allow extensions to access "regular" browser preferences. Once #6050 is fixed, the preferences should be stored in local storage, which is at least accessible via Developer Tools on the Options page. But quite frankly, this is something we still need to figure out - whether making these settings accessible in some way (or even still having them in the first place) is something that makes sense.

comment:7 Changed 2 years ago by Sworddragon

It would not be unexpected to me if we don't see the developer tools anymore at some point in the future in end user releases of Firefox so relying on them could be a bit risky. Also isn't storing data in localStorage not a bit risky? For example if an user deletes his complete history I would expect the settings to be deleted too. Or are Addons not affected by this issue or does Adblock Plus prevent this case for example by recovering its settings from memory into localStorage if it notices localStorage was deleted before?

Last edited 2 years ago by Sworddragon (previous) (diff)

comment:8 Changed 2 years ago by kzar

  • Cc kzar added
  • Component changed from Unknown to Platform
  • Resolution set to rejected
  • Status changed from new to closed

From the discussion here it seems that this behaviour is expected, so I'm closing this issue for now.

I have added the idea of providing a way for users to edit their Adblock Plus preferences to the list of suggestions we've received since the 3.0 release though, hopefully we can provide this in the future for you. Thanks for the useful feedback.

Note: See TracTickets for help on using tickets.