Opened 7 months ago

Closed 7 months ago

Last modified 6 months ago

#6070 closed defect (fixed)

Filter list not loaded after install without internet

Reported by: diegocarloslima Assignee: diegocarloslima
Priority: P2 Milestone: Adblock-Browser-for-Android-1.3.3
Module: Adblock-Browser-for-Android Keywords:
Cc: mario, tpregueiro, jwangenheim Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: yes Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29617588/

Description (last modified by mario)

Environment

One Plus 5
Android 7.1.1
Adblock Browser 1.3.2 (also happens on previous version 1.2.0)

How to reproduce

  1. Turn on airplane mode on the device
  2. Install ABB and open it
  3. After one minute, turn of airplane mode
  4. Navigate to a page where you should have ads blocked (or this ABP test page)

Observed behaviour

No ads are blocked (in case of the test page it shows EasyList is NOT installed/enabled) even though English/EasyList is enabled in Settings -> Ad blocking -> Languages. This is because the browser hasn't downloaded the filter list with the filter rules yet

Expected behaviour

After a short period of time, the browser should be able to block ads by downloading the filter lists ASAP. This happens because the ABP extension has a default retry time of 1 day when the filter fails to download, even if the filter was never downloaded before

Hint for testers

With this fix we've adjusted the time to check for and retry filter list downloads to every two minutes (starting 1 minute after the app loaded) instead of every 24 hours, as mobile connection can be flaky. In order to verify the fix, you'll need to wait a few minutes after re-enabling the internet connection before ad blocking works (instead of 24h).

Change History (9)

comment:1 Changed 7 months ago by diegocarloslima

  • Description modified (diff)

comment:2 Changed 7 months ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 7 months ago by abpbot

A commit referencing this issue has landed:
Issue 6070 - Filter list not loaded after install without internet

comment:4 Changed 7 months ago by diegocarloslima

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 7 months ago by mario

  • Milestone set to Adblock-Browser-for-Android-1.3.3

comment:6 Changed 7 months ago by mario

Assigned milestone prematurely for internal announcement purposes.

comment:7 Changed 7 months ago by mario

  • Description modified (diff)

comment:8 Changed 7 months ago by mario

  • Description modified (diff)

comment:9 Changed 6 months ago by traynard

  • Verified working set

LGTM

Note: See TracTickets for help on using tickets.