Opened 8 months ago

Closed 6 weeks ago

Last modified 6 weeks ago

#6077 closed change (fixed)

Create script to modify the list of search engines dynamically

Reported by: jwangenheim Assignee: jwangenheim
Priority: P2 Milestone: Adblock-Browser-for-Android-1.4.0
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By: #6076
Blocking: Platform: Adblock Browser for Android
Ready: no Confidential: no
Tester: Unknown Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29633555/
https://codereview.adblockplus.org/29633713/

Description (last modified by diegocarloslima)

Background

The way how search engines are selected and sorted changed in Firefox 55. Due to this change we had to remove the old logic of ordering search engines for the ABB merge with Fennec 56. On top of that, we need a script to modify list.json (which contains the logic for ordering search engines for all locales) to sort the engines with our custom ordering.

What to change

Write a script to sort the list of search engines with our custom ordering. Use the order from transform_locales.py and add ecosia.xml to adblockbrowser/file/abb_fennec_56_0_merge/mobile/locales/searchplugins
Information about the correct sorting can be also found here: https://issues.adblockplus.org/ticket/5518

Change History (12)

comment:1 Changed 8 months ago by diegocarloslima

  • Description modified (diff)

comment:2 Changed 8 months ago by diegocarloslima

  • Platform changed from Unknown / Cross platform to Adblock Browser for Android

comment:3 Changed 8 months ago by jwangenheim

  • Blocking 6076 removed

comment:4 Changed 8 months ago by jwangenheim

  • Blocked By 6076 added

comment:5 Changed 7 months ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 7 months ago by diegocarloslima

  • Milestone set to Adblock-Browser-for-Android-next

comment:7 Changed 6 months ago by abpbot

comment:8 Changed 6 months ago by jwangenheim

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:9 Changed 6 months ago by abpbot

comment:10 Changed 6 weeks ago by traynard

  • Resolution fixed deleted
  • Status changed from closed to reopened

Ecosia is now missing from the search engine list. reopening this ticket to have it investigated.

comment:11 Changed 6 weeks ago by traynard

  • Resolution set to fixed
  • Status changed from reopened to closed

The issue is now resolved. My devices were not registering the proper language when setting it to English(US) and it was causing the issue with Ecosia not showing up. The issue is now resolved and I can see Ecosia as expected.

comment:12 Changed 6 weeks ago by traynard

  • Verified working set
Note: See TracTickets for help on using tickets.