Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#6084 closed defect (fixed)

Filtering requests in Adblock Plus developer tools pane by request URL is broken

Reported by: greiner Assignee: kzar
Priority: Unknown Milestone:
Module: User-Interface Keywords:
Cc: kzar Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29616579/

Description (last modified by kzar)

Environment

Ubuntu 16.04
Chrome 62
Adblock Plus 3.0.1

How to reproduce

  1. Go to https://www.greinr.com/
  2. Open DevTools and switch to "Adblock Plus" tab
  3. Reload page to populate blockable items list
  4. Press CTRL+F to show search input field
  5. Search for "woff"

Observed behaviour

List is emptied

Expected behaviour

List only shows items whose URL contains the string "woff"

Notes

  • This is a regression caused by the changes for #6035, I updated the class name for the request's URL to resource-link but forgot to update the corresponding classname in devtools-panel.js.

Change History (6)

comment:1 Changed 2 years ago by kzar

  • Component changed from Platform to User-Interface
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 2 years ago by kzar

  • Platform changed from Unknown / Cross platform to Chrome
  • Summary changed from DevTools search broken to Filtering requests in Adblock Plus developer tools pane by request URL is broken

comment:3 Changed 2 years ago by kzar

  • Description modified (diff)
  • Owner set to kzar

comment:4 Changed 2 years ago by abpbot

A commit referencing this issue has landed:
Issue 6084 - Use new classname for devtools request URL filtering

comment:5 Changed 2 years ago by kzar

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 2 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Fixed. Filtering requests appears to work as expected.

ABP 3.0.1.1939
Firefox N/A (doesn't seem to support filtering)
Chrome 52 / 62 / Windows 10
Opera 39 / 49 / Windows 7

Note: See TracTickets for help on using tickets.