Opened 19 months ago

Last modified 5 months ago

#6091 closed defect

"Hide targeted messages?" notification shown for websites which don't use targeted messaging — at Version 11

Reported by: kzar Assignee:
Priority: P2 Milestone:
Module: User-Interface Keywords:
Cc: mapx, jsonesen, sebastian, mjethani, Ross, greiner, arthur, SMed79 Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29785581/

Description (last modified by kzar)

Background

We're getting multiple reports from users (and some of the team) that the "Hide targeted messages?" notification is showing up whenever they open a new page.

Environment

Chrome (62.0.3202.94), Windows 10 OR Ubuntu 16.04 LTS
Adblock Plus 1.13.4 installed in a fresh Chrome profile

How to reproduce

  1. Browse to https://github.com OR ​https://happyasis.com/ OR many other websites

Observed behaviour

"Hide targeted messages?" notification is displayed.

Expected behaviour

The notification should only show up for websites that do use targeted messaging.

Notes

  • User reports: topic 54550, topic 54551, topic 54555.
  • The problem is not reproducible with the latest development build, but is with the latest stable build.
  • Earliest report of the problem is yesterday (Thursday 23rd November) afternoon German time, but we're not sure when exactly the problem begun.
  • Relevant code is in adblockplusui/lib/antiadblockInit.js and string is notification_antiadblock_message.

Change History (11)

comment:1 Changed 19 months ago by kzar

  • Description modified (diff)

comment:2 Changed 19 months ago by arthur

  • Cc greiner added

I can reproduce it with a fresh Chrome (62.0.3202.94 (Official Build) (64-bit)) browser profile on Windows 10, installed ABP from https://adblockplus.org/. When I go to google.com, I'm redirected to google.de but I can click on "use Google.com" in the bottom right corner. The message appears there for me. Also when I just go to https://happyasis.com/.

comment:3 Changed 19 months ago by greiner

Note that this issue doesn't occur in the latest development build but can be reproduced using the latest stable build and going to github.com, for instance.

comment:4 Changed 19 months ago by kzar

  • Cc arthur added
  • Description modified (diff)

Thanks guys, I've updated the description to add those steps.

comment:5 Changed 19 months ago by kzar

  • Description modified (diff)

comment:6 Changed 19 months ago by kzar

  • Description modified (diff)

comment:7 Changed 19 months ago by kzar

  • Description modified (diff)

comment:8 follow-up: Changed 19 months ago by Ross

I haven't reproduced this yet. I can trigger the message but it only appears once, not matter if I answer yes or no.

ABP 1.13.4
Chrome 62 / Windows 10

comment:9 Changed 19 months ago by kzar

  • Description modified (diff)

comment:10 in reply to: ↑ 8 Changed 19 months ago by greiner

Replying to Ross:

I haven't reproduced this yet. I can trigger the message but it only appears once, not matter if I answer yes or no.

The issue is not that it reappears. In fact, you're describing the expected behavior because it's only supposed to reappear if you close the popup without answering the question.

The issue is that the message appears even on sites which don't contain any anti-adblock messages.

Last edited 19 months ago by greiner (previous) (diff)

comment:11 Changed 19 months ago by kzar

  • Description modified (diff)
  • Summary changed from "Hide targeted messages" notification showing up everywhere to "Hide targeted messages?" notification shown for websites which don't use targeted messaging
Note: See TracTickets for help on using tickets.