Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#6095 closed change (fixed)

Update the adblockplusui dependency to revision 03782f54c041

Reported by: saroyanm Assignee: kzar
Priority: P2 Milestone: Adblock-Plus-3.0.2-for-Firefox
Module: Platform Keywords:
Cc: kzar, greiner, sebastian Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29617568/

Description (last modified by kzar)

Background

We've pushed several bugfixes to adblockplusui recently, namely #5972, #6062, #6075, #6082. It would be great for them to make the next Firefox bug fix release.

What to change

Update the adblockplusui dependency to hg: 03782f54c041 git:c762275.

Hint for testers

  • There are some cosmetic changes to the new options page, so test that still looks OK on Firefox. (One note-worthy change is #6075 which should hide the Acceptable Ads Notification when conflict between EasyPrivacy and Acceptable Ads is resolved without updating the page.) The links on the Help tab have also been adjusted so that instead of the "report ad" and "report issue" buttons there's an link to support@….
  • The title of the new options page is fixed too, check it's "Adblock Plus Options" instead of "Settings".
  • The social media icons and icons used on the options page have been tweaked, check those still look OK.

Attachments (1)

6095-bubble-border-gecko.png (36.5 KB) - added by kzar 2 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 2 years ago by kzar

  • Cc sebastian added
  • Description modified (diff)
  • Priority changed from Unknown to P2
  • Ready set
  • Summary changed from Update adblockplusui dependencies to 03782f54c041 to Update the adblockplusui dependency to revision 03782f54c041

comment:2 Changed 2 years ago by kzar

  • Owner set to kzar

comment:3 Changed 2 years ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

I think there might be a regression, I'm seeing a black border around the popup window on Firefox. I'll attach a screenshot now.

Changed 2 years ago by kzar

comment:4 Changed 2 years ago by kzar

  • Description modified (diff)

comment:5 Changed 2 years ago by kzar

  • Description modified (diff)

comment:6 Changed 2 years ago by kzar

OK it turned out the black border was being caused by the extensions.webextensions.remote Firefox option I was testing on Linux.

comment:7 Changed 2 years ago by abpbot

comment:8 Changed 2 years ago by kzar

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:9 Changed 2 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

Done. These changes all seem fine.

ABP 3.0.1.1939
Firefox 52 / 57 / Windows 10
Chrome 52 / 62 / Windows 7
Opera 39 / 49 / Windows 7

Note: See TracTickets for help on using tickets.